Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am configuring a webserver in Ubuntu 10.04. More particularly I am installing DataStax OpsCenter.

Unfortunately, the logs are spammed with this error:

ERROR [pool-3-thread-7] 2013-02-15 22:04:34,533 Long os-stats collector failed: Process failed: cat /proc/partitions
  Exit val: 1
cat: /proc/partitions: No such file or directory
ERROR [pool-5-thread-3] 2013-02-15 22:04:56,846 Error getting devices and partitions #<IOException Process failed: cat /proc/partitions
  Exit val: 1
cat: /proc/partitions: No such file or directory>

Why do I get cat: /proc/partitions: No such file or directory?

I really doubt that the problem is with the application I am using, because if I run this command from command line cat /proc/partitions I still get No such file or directory and from what I have found in some forums that directory should be created when the OS is starting up, I could be wrong but that's as far I got.

share|improve this question
Hello Linas and welcome on Ask Ubuntu ! Could you please tell again what version of Ubuntu you are using (10.04 or 12.04) ? Furthermore, could you tell us what you try to install and what tutorial you are following ? Usually, "No such file or directory" means that the directory doesn't exist. – Agmenor Feb 15 '13 at 23:25
@Agmenor please see my updated question – Linas Feb 16 '13 at 0:38
When you reboot -- and before opening DataStax OpsCenter -- does /proc/partions exist? – chaskes Feb 16 '13 at 3:38
@chaskes no it doesn't – Linas Feb 16 '13 at 12:42
Are you using a VPS? Does /proc/diskstats exist? – qbi Feb 17 '13 at 10:51
up vote 2 down vote accepted

As you said in your comment, you're on a virtual private server (VPS). OpenVZ as well as other VPS solutions don't offer access to /proc/partitions. The whole /proc partition is a virtual filesystem (procfs). The structure is maintained in the kernel. So it will not work to manually create the file.

The DataStax OpsCenter has a support forum. At the moment I found no questions qhich deal with your problem. However the experts there should be able to help you out.

share|improve this answer
Well that explains it, i will try my luck there then, thanks – Linas Feb 18 '13 at 14:07

To get proc file system you might need to mount it.

mount proc /proc

To get list of partitions I use following commands. Each of them gives list of partitions.

fdisk -l 
parted -l
df -h

Note: mount only displays list of volumes currently mounted and df shows statistics of mounted volumes.

Answer created by @Shiplu in a Stack Overflow tread.

share|improve this answer
Just tried that and it says proc already mounted – Linas Feb 16 '13 at 12:43

Try making the folder yourself. This is how you do it: in a terminal, type

sudo mkdir /proc
sudo mkdir /proc/partitions

See if your logs still appear.

share|improve this answer
Just tried that and got this: ` cannot create directory partitions': No such file or directory however i can create this dir anywhere else – Linas Feb 16 '13 at 12:45
I updated the answer, can you say whether the /proc/partitions folder then exists ? – Agmenor Feb 16 '13 at 13:27
tried to run both commands, for the first one it says that /proc dir already exists and for the second one i still get cannot create directory /proc/partitions': No such file or directory – Linas Feb 16 '13 at 14:09

Installation steps to install pro* C / proc / pro c SK Vandeyaer download all this software for windows 32 bit from oracle site :


Extract all to a single folder ... keep all the contents under a single folder. check if proc.exe and oci.dll are in same folder **otherwise it will error out.

run the proc program from command prompt

  1. start -> run -> cmd
  2. cd c:\singlefolder (contents where all the extracted contents are present)
  3. type proc - it should give out some output (if you get its installed correctly)
  4. to run - type proc progamname.pc
  5. check the same folder it should have generated a programname.c file in same directory
  6. you can run the .c file using vc++ or any c++ compiler (borland or others)

Sample program :

#include <stdio.h>
#include <conio.h>

int main(int argc, char *argv[])
  printf("Hello, world!\n");
  return 0;
share|improve this answer
I don't think it applies on this website - you're on Ask Ubuntu here and your answer is Windows specific. – gertvdijk Jul 19 '13 at 22:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.