Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm pretty new to ubuntu/linux and I guess I messed up my /etc/fstab file. Ubuntu (12.04) won't boot anymore. I've found some tips on the internet on how to fix this, but I didn't manage to get them working.

What I've tried so far is to reboot and enter recovery mode shell and edit the /etc/fstab file using #nano /etc/fstab.

I figured this won't work since the the mounted filesystem is read only. Then I tried #mount -n -o remount,rw / at the shell in order to remount the filesystem as writable. But if I enter now #nano /etc/fstab I get the line bash: /usr/bin/nano: Permission denied. Am I missing something here?

Another option I've tried is to create a bootable USB drive (I don't have a CD drive). This didn't work. I created a bootable USB stick and it boots on other machines, but not on my laptop (yes, I doublechecked the BIOS for the boot-order). Any help would be very very much appreciated.

share|improve this question
    
Well that seems weird, so you cannot even run the nano program? What is output when you enter the command ls -l /usr/bin/nano? –  Wolter Hellmund Feb 15 '13 at 21:48
    
You did this process to enter in recovery mode? –  Lucio Feb 16 '13 at 0:25
    
@Wolter, when I enter this before attempting to remount, I get the following: lrwxrwxrwx 1 root root 9 May 9 2012 /usr/bin/nano -> /bin/nano. If I then try to remount using #mount -n -o remount,rw / then I get "Permission denied" on every command that I enter. –  Malker S. Feb 16 '13 at 5:43
    
@Lucio, no, I didn't follow these exact steps. In my case, the Grub menu comes up automatically (I don't have to press Shift). But apart from this it is identical: I select Recovery mode on the first screen and root on the next one. –  Malker S. Feb 16 '13 at 5:47

1 Answer 1

Problem solved. I checked the partition table using fdisk. I figured that there are more then 1 partition (one for example DELLUTILITY). I assumed that simply remounting using the line #mount -n -o remount,rw / might mount the wrong partition. So I tried #mount -n -o remount,rw /dev/sda3 / instead and that worked just fine. I was able to get r/w access to the fstab file, fix it using nano, reboot and be happy.

Thanks anyways for your interest.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.