Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having problems with the microphone making a annoying noise that makes talking really hard.

My laptop is a ThinkPad Edge 13 (the version with an intel processor)

I reported a bug [1] and I got the following response:

unsolicited event should not be enabled on internal Mic which does not support Jack detection Misc = NO_PRESENCE

I reported the following log [2]

The problem appears in both 12.04 and 12.10.

I want to know how to fix it. And if it is possible how I can help so that this error doesn't happen in the future to anybody.



share|improve this question
up vote 2 down vote accepted

I am not getting information from any of the sources which is quite sad.

Here is my workaround for the people to come:

If you use the alsamixer you can reduce the analogic mic boost to the minimum. That way the sound is extremely low but at least the noise is smaller. Then the other people via video chat must raise their volume and it's really inconvenient for many applications.

The other problem is that I don't have support for headsets with microphone. If I want them to work I must specify just one of the sides (right or left) as the volume side to avoid noises but I cannot use the microphone.

I hope it helps for somebody.

share|improve this answer

I did the following to disable the external microphone temporarily: install and run Pulse audio control (pavucontrol); go to Input Devices; mute "Microphone"; unmute and raise the volume of "Internal microphone".

share|improve this answer
What is the result? Does it make the internal microphone work without noise? – Davisein Feb 25 '15 at 10:58
Yes, the noise disappears. But this works only for that session (probably until pavucontrol is open, Ubuntu reboot or next Skype call - did not investigate) – Valentas Feb 25 '15 at 11:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.