Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Steam on my 64 bits PC, but when I tried to run it it did nothing. I then tried to run the program via terminal, and all I got was this message:

/usr/bin/steam: line 192: /home/pauix/.local/share/Steam/steam.sh: Success

Seeing that there was something wrong with the file "steam.sh", I decided to check it, and it was completely empty (which I guess it shouldn't be). Is there any way to fix this problem?

Thanks in advance.

share|improve this question
    
which Ubuntu version are you running? –  Stefan Feb 15 '13 at 18:58
1  
Please re-install steam using these instructions. link To remove steam open a Terminal with Ctrl+Alt+T and type: sudo apt-get --purge remove steam && rm -rm ~/.local/share/Steam –  efthialex Feb 15 '13 at 19:35
add comment

1 Answer

Based on efthialex's comments, uninstall Steam like this:

sudo apt-get purge steam
rm ~/.local/share/Steam -rf

then reinstall using:

sudo dpkg -i steam_latest.deb
sudo apt-get install -f

A new windows will pop out, click on the button Start Steam.

share|improve this answer
    
Be careful with the rm command. To prevent errors, I have swapped the directory and options, so you cannot accidentally run rm -rf ~/.local/ or something. –  Lekensteyn Feb 16 '13 at 13:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.