Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running ubunut 12.04.

Today a software updater told me to install a few libqt4 packages which i did. I got the problem below which i think other people might have after today.

trying to install this new package libqt4-dbus 4:4.8.1-0ubuntu4.4 that came from the update manager. It gives an error though because of dependencies.

This is the exact error broken down

libqt4-dbus : Depends: libqt4-xml (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is installed
           Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is installed
           Recommends: qdbus (= 4:4.8.1-0ubuntu4.3)

from looking at ubuntu website http://packages.ubuntu.com/precise/libqt4-dbus

libqt4-dbus 4:4.8.1-0ubuntu4.4 relies on 4:4.8.1-0ubuntu4.4 software and not on 4:4.8.1-0ubuntu4.3 software.

Why is the installer saying it relies on a lower version? Also is i thought 4:4.8.1-0ubuntu4.4 would be compatible with with 4:4.8.1-0ubuntu4.3 since it would be backward

thanks for the reply. That output is confusing then if it is trying to say what your said. i think they should remove the word "but" from it. That is what makes me think it is looking for the older version.

I checked the packages and they are the latest software for evverything.

ii  libqt4-xml                              4:4.8.1-0ubuntu4.4                       Qt 4 XML module

That output is confusing then if it is trying to say what your said. i think they should remove the word "but" from it. That is what makes me think it is looking for the older version.

I checked the packages and they are the latest software.

ii  libqt4-xml                              4:4.8.1-0ubuntu4.4                       Qt 4 XML module
ii  libqt4-xml:i386                         4:4.8.1-0ubuntu4.4                       Qt 4 XML module
ii  libqtcore4                              4:4.8.1-0ubuntu4.4                       Qt 4 core module
ii  libqtcore4:i386                         4:4.8.1-0ubuntu4.4
ii  libqt4-xml:i386                         4:4.8.1-0ubuntu4.4                       Qt 4 XML module
ii  libqtcore4                              4:4.8.1-0ubuntu4.4                       Qt 4 core module
ii  libqtcore4:i386                         4:4.8.1-0ubuntu4.4

So in the sentence above for libqt4-xml it is correct in saying that 4:4.8.1-0ubuntu4.4 version is installed. Not sure why it would say that an older version is available when the newest version is installed.

libqt4-dbus : Depends: libqt4-xml (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is installed
share|improve this question
add comment

2 Answers

solved the problem today. I had to install the libqt4-dbus:amd64 package to get the normal libqt4-dbus package to update. Found it out when i tried to force install the libqt4-dbus:i386 package.

emarnau@eld1256hzj-l7:~/Downloads$ sudo dpkg -i libqt4-dbus_4.8.1-0ubuntu4.4_i386.deb (Reading database ... 219816 files and directories currently installed.) Preparing to replace libqt4-dbus:i386 4:4.8.1-0ubuntu4.4 (using libqt4-dbus_4.8.1-0ubuntu4.4_i386.deb) ... Unpacking replacement libqt4-dbus:i386 ... dpkg: error processing libqt4-dbus:i386 (--install): libqt4-dbus:i386 4:4.8.1-0ubuntu4.4 cannot be configured because libqt4-dbus:amd64 is in a different version (4:4.8.1-0ubuntu4.3)

emarnau@eld1256hzj-l7:~/Downloads$ sudo dpkg -i libqt4-dbus_4.8.1-0ubuntu4.4_amd64.deb (Reading database ... 219816 files and directories currently installed.) Preparing to replace libqt4-dbus 4:4.8.1-0ubuntu4.3 (using libqt4-dbus_4.8.1-0ubuntu4.4_amd64.deb) ... Unpacking replacement libqt4-dbus ... Setting up libqt4-dbus (4:4.8.1-0ubuntu4.4) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place

ii  libqt4-dbus                             4:4.8.1-0ubuntu4.4                       Qt 4 D-Bus module
ii  libqt4-dbus:i386                        4:4.8.1-0ubuntu4.4                       Qt 4 D-Bus module

Odd that the apt could not figure this out. Maybe because i386 package is always installed before the amd 64 package. if it was the other way around it would of fixed it.

share|improve this answer
add comment

The updater isn't saying it requires an older version. It says only the older version is available, and it depends on the newer version. 4:4.8.1-0ubuntu4.4 is newer than 4:4.8.1-0ubuntu4.3.

Most likely you are using a mirror that is slightly out of sync with the archive, and has only some of the packages synchronized over to it. If you wait a while and try again later, it should work. Or you could switch to a different mirror.

share|improve this answer
    
thanks for your help –  martin naughton Feb 18 '13 at 10:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.