Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After starting steam with "force_s3tc_enable=true steam" then stating TF2 game, the screen was the following:

1) black screen
2) green screen
3) Shift+Tab valve popup
4) Black screen (long time)
5) Incomplete TF2 menu sceen ( )
6) I even could leave the game ( )

"Any suggestions on how to solve it?"

share|improve this question
Do you have the latest video drivers? – tikend Feb 15 '13 at 13:26
When I activated ATI/AMD proprietary FGLRX graphics driver (* * experimental * * beta), Steam doesnt start. So I kept the open drivers. – guest Feb 15 '13 at 13:35

Open drivers doesn't support full 3D, so if you wanna play games, you need to install latest stable proprietary drivers. Here is how where you can download the latest drivers for your graphic card from AMD site and use them instead of 12.6

share|improve this answer
I installed the stable (and not stable) versions available on "System Settings" > "Additional drivers": Original, Post-release and Experimental ATI/AMD proprietary FGLRX graphics drivers (Its easier to add/remove, and I believe its similar to the version from AMD site). Steam doesnt start with any of the versions. Maybe this info is useful: I uploaded the terminal feedback when Post-release version was activated to – guest Feb 15 '13 at 14:35
So TF2 isn't working correctly or Steam at all? – tikend Feb 15 '13 at 15:06
Steam at all. "fglrxinfo" returned errors. After lots of failed loops, Steam is again working, with original version of FGLRX. I think the "clean" procedure I followed is (1) install FGLRX original from Additional drivers, (2) reboot, (3) run "sudo aticonfig --initial", (4) reboot, (5) start Steam -> it is working in FGLRX. My present step is to attend the requirement of a newer version of FGLRX. – guest Feb 15 '13 at 16:52
TF2 is working. And that is weird... I tried to upgrade to the Experimental FGLRX version, but it was aborted late in installation. The same for Post-realease version. After that, installed again the Original version, then removed it (my plan was to install Experimental version, without no version of FGLRX installed, i.e., from the open source version). So, using the open source version, I tried to open TF2, and it worked!! There is some sound issues, but it is working... weird... – guest Feb 15 '13 at 17:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.