Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm really new to Ubuntu, so you have to be really patient with me. So, I installed Ubuntu 12.10 two weeks ago. Everything works, it's kinda slow, but I think that's because of the ancient laptop I use.

Anyways! I tried to install Steam and Team Fortress 2, but when I want to start the game, I get some errors about OpenGL not being properly installed or working. I tried to update the drivers, but it's no use.

I'm on a Radeon X1200 / RS690M.

So, does anybody have a clue?

share|improve this question

You need to install latest proprietary drivers, I just explained why and how here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.