Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I couldn't remember the password that I've used for so many weeks, and changed it in recovery mode but for many reasons I decided to reinstall Ubuntu 12.10 with my seperate /home folder intact and passphrase at hand so I can decrypt my old /home when reinstalled.

Now I that all is going well and ubuntu 12.10 is reinstalled I want to access my old data which during the installation process I have mounted at /backups.

I'm following this guide; http://hackerpublicradio.org/eps.php?id=1101. All seems fine until step 7 where it will be mounted at /tmp/ecryptfs.45LC2WiF. When I go to this folder I can see several files and one folder, and in it a subfolder (my username).

Main /tmp/ecryptfs.45LC2WiF$ folder

  • Lost+Found (folder)
  • empec (folder, my username)
  • .ecryptfs (folder)
  • .directory (link (broken))

empec folder

  • .cache (folder)
  • Access-Your-Private-Data.desktop (Link to desktop configuration file)
  • README.txt (Link to plain text document)
  • .ecryptfs (link (broken))
  • .private (link (broken))

The readme.txt notes

THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on: "Access Your Private Data"

or

From the command line, run: ecryptfs-mount-private

When trying to open Access-Your-Private-Data.desktop, terminal opens and closes instantly. So nothing happens. And when executing ecryptfs-mount-private I get the following;

$ cd /tmp/ecryptfs.45LC2WiF/
$ ecryptfs-mount-private
ERROR: Encrypted private directory is not setup properly

How do I access the encrypted files and move, delete or alter them? Thanks in advance!

  • I do not have the old password (Or atleast I think so).
  • I have the old passphrase used to encrypt the /backups formerly /home

[updated] Changed Step 5.3 into Step 7. Problem remains the same.

share|improve this question
    
I'm also wondering how many characters a passphrase has. Because I sometimes add more characters to my passwords in order to disguise it more. –  empec Feb 15 '13 at 14:29
    
when mounting /backups, there are a lot of files and folders in the /tmp placeholder. But they are all empty (or encrypted) and have the following name; CRYPTFS_FNEK_ENCRYPTED.[some code here]. Exactly the same as the unmounted /backups dir. I'm sure I have the mount passphrase of 32 characters correct. –  empec Feb 18 '13 at 14:42

1 Answer 1

There is a few things you can try. The error message you get is itself helpful: the directory is not mounted.

If you get this type of files CRYPTFS_FNEK_ENCRYPTED.[some code here] in fact the decryption was not succesful. That means something went wrong in the decryption process (usually the problem is related to the settings you provide in the prompt). Make sure to type the full passphrase in gedit and copy it from there. I once already spend two days figuring out what went wrong decrypting and for some reason I had a tiny mistake (O as 0) in the passphrase.

You can also give this command a try:

mount -t ecryptfs [SRC DIR] [DST DIR] -o [OPTIONS]

This will do the mounting and decrypting for you. Read more here and don't stick too close to that tutorial you mention.

BTW: Is your username the same as on the old system?

share|improve this answer
    
Yes my username is the same as the old system. –  empec Feb 24 '13 at 22:48
    
was you decryption successful? did you try mount -t ecryptfs [the source directory] [the destination directory]? Can you tell us what options you choose? –  don.joey Feb 25 '13 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.