Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working on a Dell precision M4700 laptop with Ubuntu 12.04 and KDE desktop.

After a "suggested" system updating, my wireless connection has stopped working. KNetWorkManager sees the wireless and tries to connect to it but, after a while, a small windows pops up and asks for a password. If I introduce the wireless one I have, it tries again but nothing happens. That window appears again and again asking for a password. Such window has a key as a symbol on the top left corner, the same key appears over the KNetWorkManager symbol which is on the bottom panel. The window has the title Secretas de [wireless name] - Service for KDE- (I am using Spanish locale). I am sure the password is correct and the router is working fine, indeed, I am using another laptop to publish this thread using the same wireless connection.

I also post some useful information:

kernel: 3.2.0-37-generic
desktop KDE
ubuntu 12.04.2 LTS

Output of iwconfig:

lo: no wireless extension
eth1: IEEE 802.11abg ESSID off/any
Mode: managed access point: not-associated
Retry long limit:7 RTS thr off Fragment thr off
power management: off
eth0: no wireless extension

I update some information after your suggestions

after ip a :

1: lo: mtu 16436 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo inet6 ::1/128 scope host valid_lft forever preferred_lft forever

2: eth0: mtu 1500 qdisc pfifo_fast state DOWN qlen 1000 link/ether d4:be:d9:82:0a:99 brd ff:ff:ff:ff:ff:ff

3: eth1: mtu 1500 qdisc pfifo_fast state DORMANT qlen 1000 link/ether a4:17:31:4b:52:6e brd ff:ff:ff:ff:ff:ff inet6 fe80::a617:31ff:fe4b:526e/64 scope link valid_lft forever preferred_lft forever

sudo ip link set eth1 up : it's not able to connect either (yes I am using eth1).

Information of the wireless card after lspci -nn | grep 0280 is:

03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev01)


Hi, I tried the following:

hardware switch on

rfkill list all

0: dell-wifi: Wireless LAN Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no

Then, hardware switch off

rfkill list all

0: dell-wifi: Wireless LAN Soft blocked: yes Hard blocked: yes 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no

Finally I set the switch on again.

The wireless is still not working. It sees the home LAN and tries to connect again and again but it does not.

share|improve this question
    
Check the ip a command. Does sudo ip link set eth1 up work? (I assume you have wireless on eth1. –  Melon Feb 15 '13 at 13:22
    
Please edit your question to add the details of your wireless card. From a terminal: lspci -nn | grep 0280 –  chili555 Feb 15 '13 at 15:28
    
The information you ask is written above. Furthermore, I've tried to switch off the wireless device by hardware with no success, unfortunately. –  rbaena Feb 15 '13 at 23:46
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.