Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got the newest version of the XPS 13 yesterday. Has anyone managed to get an Ubuntu/Windows 8 dual boot figured out?

I tried all of the step-by-step instructions listed here: http://ubuntuforums.org/showpost.php?p=12486498&postcount=10

I've noticed that some people have had issues on the previous versions using the RHS USB 3.0 slot and had to use the USB 2.0 slot. However, both slots of this newest version are USB 3.0!!

I've even tried using an external DVD drive with a live CD.

Using the above instructions verbatim, at best the system reboots and ignores the USB/DVD. At worst, it seems to hang and do nothing. It actually has me a little concerned that it would actually recognize a rescue USB for Windows 8!!

Where it usually hangs is when I follow the instructions:

In Windows 8 find the power off icon (i.e. hit the bottom-left corner and select settings) press it and select reboot while holding the shift key down

Select "Use a device" (again translated from IT)

Select "USB Storage Device" <--- Hangs, often leaving a faded screen with the options

I have even tried making a USB option in the Bios. The problem with that, upon the next reboot, it seems to not see the USB stick that's still in the slot!!

I bought this machine purely with the intention of dual-booting. It's a beautifully awesome machine.

share|improve this question
    
"Secure Boot" is a new UEFI feature that appeared in 2012, with Windows8 preinstalled computers. The support for this feature has started with Ubuntu 12.10 64bit (see this article) and 12.04.2 64bit, but it is not fully reliable yet, so you may need to disable it in order to be able to boot Ubuntu. Source –  efthialex Feb 16 '13 at 11:12
add comment

2 Answers 2

Dual-boot on the XPS13 detailed on http://debian.netside.net/xps13_linux.html

While the setup described nukes Windows 8, you could easily keep Windows and install Linux alongside on the HD - just shrink the 222G ntfs partition #5 and use the free space to create your Linux partitions. I needed all of the disk to install two versions of Linux, so Windows is gone. It is best to first install a working Linux version on a USB stick and then use gdisk from shell to partition properly.

share|improve this answer
add comment

I had this problem on the new XPS13. I tried to boot using a USB 3 pendrive, and an external usb 3 HDD, on which i'd put the Ubuntu installer for 13.04 using the start-up disc creator tool in Ubuntu. Neither of these booted. I added the manual entry for usb boot as detailed in the other thread you linked to and that didn't work either. (I had secure boot on, rapid start off). I didn't test in legacy mode because in UEFI mode I found that my old 20GB USB2 HDD booted fine, and i could install Ubuntu. So the equivalent of the trick of using the LHS USB(2) port on the previous version of the laptop is to find out an old USB 2.0 stick. With secure boot enabled boot repair complained, so I still don't have the familiar GRUB OS selector. However pressing F12 during boot allows you to choose windows, and it boots fine. On restart it boots straight back into Ubuntu if you don't interrupt it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.