Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu Desktop 12.10 running in VMware on my Windows 7 machine for development purposes. The VM is set up as "bridged", so effectively, it looks like it is directly connected to the same switch as my host PC.

Inside Ubuntu, I have compiled and install PHP 5.4.11 and nginx 1.2.6. PHP is compiled and configured to use PHP-FPM.

I also mounted a shared folder from my host using this:

//192.168.1.3/webfiles /webfiles cifs username=user,password=password,noserverino,file_mode=0777,dir_mode=0777 0 0 

This folder is then served by nginx and php-fpm.

Previously this has worked perfectly and is quite fast. However, yesterday, I installed software updates on my Ubuntu VM since the reminder kept popping up. The VM seemed fine as I was still able to work on it with out any issues last night.

This morning, I booted up the VM and was able to browse the shares in nautilus. However, once I visit a PHP page, the share would lock up for no reason! Nginx just shows a gateway timed out message and there was nothing relevant in the PHP logs.

I am at lost as to how this could have happened as the setup has worked fine for many months. I would like to further investigate the root of this problem to fix it.

Are there any logs for the samba share on Ubuntu I can inspect to do this? Has anyone had similar issues?

Currently, these are all I have in the logs:

log.wb-UBUNTU:

[2013/02/15 13:32:56.384600,  0] winbindd/winbindd.c:212(winbindd_sig_term_handler)
  Got sig[15] terminate (is_parent=0)

log.winbindd:

[2013/02/15 13:33:49.710128,  0] winbindd/winbindd_cache.c:3147(initialize_winbindd_cache)
  initialize_winbindd_cache: clearing cache and re-creating with version number 2
share|improve this question

1 Answer 1

up vote 0 down vote accepted

After doing some back tracking, I seem to have resolved the problem.

Earlier today, I updated Kasperksy Endpoint Security from version 8 to version 10 on my host before doing any work.

After this event, I started seeing the problem.

To rule out the issue, I uninstalled KES but the issue still persists.

I then installed ESET smart security and everything seems to be fine. This leads me to believe that after KES was uninstalled, the windows firewall was automatically turned back on, which started blocking or discarding Samba packets, causing those issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.