Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to import existing SSH keys to Seahorse?

share|improve this question

closed as off-topic by Seth, Warren Hill, Eric Carvalho, Avinash Raj, blade19899 Dec 13 '13 at 15:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Warren Hill, Eric Carvalho, Avinash Raj, blade19899
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Bug Confirmed bugs.launchpad.net/ubuntu/+source/seahorse/+bug/372608 –  Braiam Dec 12 '13 at 21:13
add comment

3 Answers 3

Export and Import Keys

Seahorse can import SSH keys from the clipboard or a key file. Seahorse allows users to specify a SSH key file. Seahorse does not change the content of imported files, instead, Seahorse copies the imported files to ~/.ssh with non-duplicated file names.

Seahorse can export public key or private key info to new files. Seahorse can copy public key info to the clipboard.

open seahorse -> file - import.

share|improve this answer
    
Doesn't work for me on Ubuntu 10.10. It's as if Seahorse ignores the SSH keys. –  Christopher Parker Feb 10 '11 at 23:35
    
Error while importing private and public keys: "file:///home/manager/Desktop/id_rsa: Invalid file format". Any thoughts?.. –  aneeshep Feb 16 '11 at 5:06
    
it seems a bug in seahorse but you can copy your private key to .ssh/id_rsa and your public key to .ssh/id_rsa.pub, and it appeared in seahorse. –  hhlp Feb 16 '11 at 16:51
    
Same problem: "Invalid file format". Even tried copying the key and doing Edit->Paste Keys, as described in the Seahorse help. No luck. –  Patrick White Nov 25 '11 at 14:13
    
I ran into the "Invalid file format" error, too. However, creating an id_rsa.pub file in the same folder fixed it. You can do this with ssh-keygen -y. –  afit Apr 9 '12 at 9:15
add comment

There are bugs importing keys in "seahorse". Don't seem to be fixed in any release yet, but the bug gives workarounds.

https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/372608

share|improve this answer
add comment

if you have already generated the ssh key on the machine, then you should ssh to that machine, then execute this:

 ssh-copy-id -i ~/.ssh/id_rsa.pub user@host

user= your username of the system that you want to import

host= your pc hostname, the pc that you want to import key to.

What this happens is, that command calls the machine to send to your pc that you are trying to import the key.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.