Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I currently have the 2.9.7 version of qBittorrent.

I want to upgrade to the latest version, 3.0.8.

sudo apt-get upgrade qbittorrent returns that the program is up-to-date:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And install after removal do nothing but reinstall version 2.9.7!

What am I missing?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

The version of qBittorrent in Ubuntu is always quite old (since it's updated regularly and most feature and minor bugfix updates don't make it into the official Ubuntu version).

But there is an easy solution!

qBittorrent's author (Chrisophe Dumez) maintains a PPA providing stable qBittorrent builds. I recommend using that.

To enable this PPA and install qBittorrent from it (or upgrade the version you currently have to the version it provides), open a Terminal window (Ctrl+Alt+T) and run:

sudo add-apt-repository ppa:hydr0g3n/qbittorrent-stable
sudo apt-get update
sudo apt-get install qbittorrent

(Or you can run sudo apt-get upgrade in place of the third line--if some version of qBittorrent is already installed from Ubuntu packages, both ways work.)

I use qBittorrent from that PPA--it works great.

Source: qBittorrent Downloads page (Other Binary Packages section)

For more information on PPAs, see:

share|improve this answer
    
thanx a lot for the beautiful answer ;) it worked great. –  riimzzai Feb 15 '13 at 0:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.