Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Xubuntu 12.10 running fine on a Thinkpad T60. Grub2 is installed as the boot manager and the GRUB....LINUX_DEFAULT is set as "quiet splash". Therefore, Grub should display its splash image until plymouth takes over, as I understand it. Unfortunately, it does not. If I hold down shift to get into the boot menu, my splash image shows up, but the screen remains black. I realise it's a minor cosmetic issue, but I have found no way to fix it.

share|improve this question
I've never seen the grub splash before with 'quiet splash' set. Only plymouth. – Mark Paskal Feb 14 '13 at 22:40
That is what all the pages one can google suggest. Do you mean that the transition to plymouth takes place so early that one never sees the grub splash? In that case I would wonder why the (configured) xfce-mouse splash screen for plymouth only shows up a split second before the login window comes up. All the initramfs parameters are set up according to what I could find, so there should be no wait period between the two - yet there is. – user132060 Feb 14 '13 at 23:36
Further information: grub should display the splash - it does not. Plymouth should then take over and display the xubuntu logo - it does not. Finally, X11 takes over and it works. Let's leave grub aside for a moment. I reinstalled plymouth with synaptic and it's still not showing. I did update-alternatives and, having only the xubuntu-logo theme, of course there was nothing to update... any ideas? It seems to be a fairly common problem - there are other questions with the same symptoms, but a dearth of answers. – user132060 Feb 14 '13 at 23:56
1 expected. A further day of googling and experimenting effectively yielded nothing, which leads me to believe that either nobody cares or nobody knows how to fix it. @MarkPaskal any insight? – user132060 Feb 15 '13 at 22:57
AH. After re-reading this again and again I get it. The GRUB splash is the image shown at the kernel / OS selection dialogue. Since GRUB is set not to show up at all in Ubuntu and just boot the newest kernel you need to edit /etc/default/grub. I will add an answer. – Mark Paskal Feb 16 '13 at 6:18

First of all, the GRUB splash displays behind the text of the kernel and OS selection screen that you get to by holding Shift during boot. It does not show up by default (unless you are dual booting, although I do not own a copy of windows to my name and am not sure of this) and I don't think it works as a traditional splash (like Plymouth; please someone more knowledgeable correct me here if I am wrong).

The splash in the command line determines (on Ubuntu) if plymouth is run at all. Removing it (I often do as my graphics driver does not work well with it anyway) just shuts off the blue xubuntu screen assuming it's showing at all.

To make the GRUB menu (and your picture in the background) show up you need to edit the file /etc/default/grub and change the line that says GRUB_HIDDEN_TIMEOUT=0 to the number of seconds you want the menu to display for.

So GRUB_HIDDEN_TIMEOUT=5 for five seconds. Run sudo update-grub and then reboot.


share|improve this answer
no update-grub? – Thufir Apr 20 '13 at 6:48
@Thufir thanks for pointing that out. – Mark Paskal Apr 20 '13 at 22:03

An easy way to change grub's background: -if you have any image in /boot/grub/, remove them with

sudo rm image123.jpg

-put your new picture there, copy-and-paste -refresh grub with

sudo update-grub

-Done! Reboot and see.

share|improve this answer

I'm running XUbuntu 12.04 LTS. I went to /etc/default/grub and checked there was some time for grub start-up menu to be seen (GRUB_TIMEOUT set to more than 0). With

sudo nano /etc/default/grub

I edited the grub settings and added


at the end of the file, saving the file afterwards. Then, I copied the file starfleet.jpg to /boot/grub and entered

sudo update-grub

Among other messages, grub-mkconfig reported it found the new background file. After rebooting the system, I had the Startfleet Command logo behind the grub start-up menu.

Of course, it just appears for the time you allow the menu to be on-screen, with the countdown ticking, before grub starts the default option.

It takes way shorter to do it than to describe it. I hope this helps!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.