Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The GNS3 package in Ubuntu Software Center is old. I tried to install the new release GNS3 0.8.4 RC2 from the CLI using the following command:

sudo python gns3 0.8.4 exe (and bin) but I get a python error.

I have updated python and still get the same error.

The GNS installation instructions ar for using the Ubuntu Software Xenter for the installation but the newer releases are not found when I search for them. The releases are on my disk drive.

How can I install the packages?

share|improve this question
Could you add the output errors to your question? As well as a link to the install instructions? This will help us understand your problem better.l – Kevin Bowen Feb 14 '13 at 19:19

online method to install Gns3 easy way ?

  1. sudo su 2 enter your root password

  2. apt-get update

  3. apt-get upgrade < optional>

  4. apt-get install gns3

... that's all

share|improve this answer
sudo apt-get install gns3 will install gns... – Ravan Aug 27 '15 at 14:09

In order to start GNS3 from the command line, use the following command:

sudo python gns3

There is no need for the additional options on the command line.

Instructions for installing GNS3 from source

GNS3 is a graphical network simulator. In order to emulate Cisco network devices, the dynamips emulator will need to be installed as well.

  1. Install the following recommended packages:

    sudo apt-get install qt4-dev-tools

    sudo apt-get install pyqt4-dev-tools

  2. Before downloading the files for GNS, create the following two directories:

    sudo mkdir /opt/GNS3

    sudo mkdir /opt/GNS3/Dynamips

  3. Go to the GNS download page for the latest version (The latest version is 0.8.4-RC2) or download directly from here.

  4. Go to the dynamips download page:

  5. Go to the folder where you downloaded the two files.

    • Unpack the GNS files:
    • sudo tar -jxf GNS3-0.8.4-RC2-src.tar.bz2

    • Move the files to the /opt/GNS3 directory:

      • sudo mv GNS3-0.8.2-src/* /opt/GNS3
    • Move the dynamips binary to the /opt/GNS3/Dynamips directory:

      • sudo mv dynamips-0.2.8-RC2-x86.bin /opt/GNS3/Dynamips
    • Change the permissions on the Dynamips binary to make it executable:

      • sudo chmod +x /opt/GNS3/Dynamips/dynamips-0.2.8-RC2-x86.bin
  6. Start GNS3
    • sudo python gns3

I would recommend taking a look at the following video from the GNS3 team for further instructions and decent explanation of validating the rest of your GNS3 installation.

GNS3 installation tutorial. There is also updated GNS3 installation instructions for Linux on the main GNS3 site.

share|improve this answer

Ubuntu-based distributions (64-bit only)

Run the following commands in a terminal:

sudo add-apt-repository ppa:gns3/ppa
sudo apt-get update
sudo apt-get install gns3-gui

If you want IOU support:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install gns3-iou

Check these documents

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.