Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus laptop (non zenbook) which I purchased last week. It has an Elantech Touchpad on it. Here's what's working:

  • Edge scrolling or Two Finger Scrolling.
  • Three finger and Two finger.
  • Left Click and Right Click and double tap.

The only thing keeping this from being perfect is that when I'm typing sometimes my palm hits the touchpad just right and then things get crazy. That can be a real bother when writing code.

Can someone help?

Here's the output of xinput list:

 Virtual core pointer                       id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ ASUS USB2.0 Webcam                        id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

output of: ps aux | grep syndaemon

jason 2911 0.0 0.0 20208 948 ? S Feb13 0:53 syndaemon -i 2.0 -K -R -t

jason 10256 0.0 0.0 13584 928 pts/2 S+ 14:18 0:00 grep syndaemon

share|improve this question
1  
There is a checkbox for that in the Mouse and Touchpad settings. Is it checked? –  mikewhatever Feb 14 '13 at 19:11
    
Yes, it is. It didn't make any difference. :( –  Jason Shultz Feb 14 '13 at 20:03
    
Let's see the output of ps aux | grep syndaemon. If possible, add it to the original question. –  mikewhatever Feb 14 '13 at 20:18
    
done. I added the output of ps aux | grep syndaemon as requested. –  Jason Shultz Feb 14 '13 at 21:20
    
Looks ok. Are you saying the feature doesn't work at all? What happens exactly, when you hit it 'just right'? –  mikewhatever Feb 14 '13 at 21:46
show 5 more comments

3 Answers 3

I know it's not what you really want (completely automatic?), but there is an easy to make keyboard shortcuts to disable and enable the touchpad.

From your xinput list, the id for your touchpad is 12. Use this command to disable it:

xinput set-prop 12 "Device Enabled" 0

Use this to enable it:

xinput set-prop 12 "Device Enabled" 1

Bind these commands to your custom shortcuts (Keyboard / Shortcuts / Custom Shortcuts). Perhaps this can be made to a script?

share|improve this answer
add comment

Two ways I know for disable touchpad while typing. First the graphical way. Click on Dash and write : touchpad , then click "mouse and touchpad" to open and tick the box "Disable touchpad while typing"

enter image description here

The second (I think is the same) is the terminal way .. Open a terminal (CTRL+ALT+T) and write

syndaemon -i 2 -d 

The number after -i indicates the seconds after the last key pressing for the touchpad to be working again. The -d option is for syndaemon to continue running in background (as daemon).

share|improve this answer
add comment

Start synaptiks. I had a bit of problem with this as it sometimes fails to start. Try to start it again until you see the GUI dialog.

In the dialog you can set 'Automatically switch off touchpad on keyboard activity' and the 'Time to wait before switching the touchpad on again'.

You can also set 'Automatically switch off touchpad if a mouse is plugged'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.