Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 1 TB external hard drive and I can't write anything on there. I have some movies on there and I can watch them perfectly fine but I can copy new files to there, it's just grayed out.

i know this is 13.04 but i've tried 12.10 also and this shouldn't have anything to do with that i'm running an alpha release.

I have tried:

sudo chmod 777 -f -R /media/jeggy/INTENSO

but that didn't work, any help would be great


jeggy@jeggy-XPS:~$ mount | grep INTENSO
/dev/sdb1 on /media/jeggy/INTENSO type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)


jeggy@jeggy-XPS:~$ ls -l /media/jeggy/INTENSO
ls: cannot access /media/jeggy/INTENSO/lampp: Input/output error
total 128
drwx------  10 jeggy jeggy 32768 jan  2 23:11 B
drwx------   5 jeggy jeggy 32768 feb 12 23:31 b2
drwx------ 131 jeggy jeggy 32768 feb 13 00:33 Filmar
drwx------   3 jeggy jeggy 32768 des 26 16:29 Jebster
d?????????   ? ?     ?         ?            ? lampp

This is what i get and after i followed the instructions by Luis Alvarado
and now "New Folder" isn't grayed out but i get this when trying to create one:

enter image description here Leyp um = Skip

And the lampp folder is a folder i thought i lost yesterday, so if there's anyway i can get that folder back, it would be very great as there is some PHP codes i have been working on and maybe my last chance of ever getting them back.

UPDATE:

jeggy@jeggy-XPS:~$  fsck /media/jeggy/INTENSO
fsck from util-linux 2.20.1
e2fsck 1.42.5 (29-Jul-2012)
fsck.ext2: Is a directory while trying to open /media/jeggy/INTENSO

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>



jeggy@jeggy-XPS:~$ sudo fsck.vfat -r /dev/sdb1
dosfsck 3.0.13, 30 Jun 2012, FAT32, LFN
File system has 30516268 clusters but only space for 30516222 FAT entries.

jeggy@jeggy-XPS:~$ sudo fsck.vfat -r -u /media/jeggy/INTENSO/lampp /dev/sdb1
dosfsck 3.0.13, 30 Jun 2012, FAT32, LFN
File system has 30516268 clusters but only space for 30516222 FAT entries.

And still nothing works :(

share|improve this question
1  
Is it mounted automatically, when you plug it in? Please, post the output of mount | grep INTENSO. –  Pavel A Feb 14 '13 at 15:02
1  
I wonder if fsck /media/jeggy/INTENSO would help? –  Pavel A Feb 14 '13 at 15:52
    
i added the output of that –  Jeggy Feb 14 '13 at 16:45
    
It turns out you have to use fsck.vfat directly. Try this: sudo fsck.vfat -r /dev/sdb1. You may also want to try this: sudo fsck.vfat -r -u /media/jeggy/INTENSO/lampp /dev/sdb1, but be careful and better read the man page first. Before doing anything, I'd remount it (may be ??? will go away). –  Pavel A Feb 14 '13 at 17:28
    
I was not able to reproduce the issue with question marks (may be I’ll try later), but all those threads on the Internet suggest you have to make sure you have read and execute permissions on folders (to be able to list them). See this page - ubuntuforums.org/showthread.php?t=1914680 (posts #9 and 10). –  Pavel A Feb 14 '13 at 17:53
show 1 more comment

1 Answer

I would first (After you did the chmod) see who owns the HDD:

cyrex@cyrex:~$ ls -l /media/cyrex/ 
total 16
drwx------  1 cyrex cyrex 4096 Feb 13 16:54 77C3804A2E728AFA
drwx------  7 cyrex cyrex 8192 Dec 31  1969 CYREX
drwxrwxrwx 18 cyrex cyrex 4096 Feb 13 14:43 xtreme

Like the example above I would ls -l /media/jeggy and see what it says about INTENSO. If the user an group are yours then we continue with the following step, if not we change it:

sudo chown -fR jeggy:jeggy /media/jeggy

Then just in case we do:

sudo chmod 777 -fR /media/jeggy/INTENSO

Before doing all of this of course, the HDD should be mounted. If it is not, then it will not work. So make sure it is mounted before doing chmod or chown. You can also get the information about how it was mounted by typing mount.

And just in case it still not work I would look into /etc/fstab to see if the HDD is there and is being mounted with other flags and options. If it is, remove it or change the flags and options to yours.

In relation to the use of fsck, you need to know several things, first you are suppose to use it with the device in question, which is found in /dev/ no to the mounted folder it was assigned to. So

fsck /media/jeggy/INTENSO would be wrong

fsck /dev/sda1 would be right

There is no need to add the type of filesystem for fsck (Except in the case of trying to repair a NTFS filesystem, in which case you would use ntfs3g instead of fsck). So

fsck.vfat -r /dev/sdb1 is the same as fsck -r /dev/sdb1 because fsck will first look for what type of filesystem the device has and with it determined how to proceed. If the filesystem is fat, then it will automatically run fsck.vfat. Same for ext2, ext4 and any others supported.

Another tip is that I would go with the -p or -y parameters instead of the -r because they are compatible between each fsck command, so I would run either one of the following lines:

sudo fsck -p /dev/sdb1 -- Automatic Repair
sudo fsck -y /dev/sdb1 -- Assume yes to all questions

NOTE: the -y in fsck is the same as -a in the fsck.vfat command. It is compatible with both.

Lastly, if you want to force a check + repair on the drive I would do the following:

sudo fsck -fy /dev/sdb1 -- Force Check + Assume yes to all questions

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.