Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I restart my apache server using the command

sudo /etc/init.d/apache2 restart

I get the following error:

Restarting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
... waiting apache2:
Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Is the server using 127.0.1.1 instead of 127.0.0.1? What causes this error?

share|improve this question

8 Answers 8

up vote 189 down vote accepted

13.04 and older

This is just a friendly warning and not really a problem (as in that something does not work).

If you insert a

ServerName localhost   

in either httpd.conf or apache2.conf in /etc/apache2 and restart apache the notice will disappear.

If you have a name inside /etc/hostname you can also use that name instead of localhost.


And it uses 127.0.1.1 if it is inside your /etc/hosts:

127.0.0.1 localhost
127.0.1.1 myhostname

Preferred method

Troubleshooting Apache

If you get this error:

apache2: Could not determine the server's fully qualified domain name, 
using 127.0.0.1 for ServerName

then use a text editor such as "sudo nano" at the command line or "gksudo gedit" on the desktop to create a new file,

sudo nano /etc/apache2/conf.d/fqdn

or

gksu "gedit /etc/apache2/conf.d/fqdn"

then add

ServerName localhost

to the file and save. This can all be done in a single command with the following:

 echo "ServerName localhost" | sudo tee /etc/apache2/conf.d/fqdn

But on Ubuntu 14.04:

 echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/fqdn.conf
 sudo a2enconf fqdn

Don't forget the ".conf" (without will not work).

share|improve this answer
1  
thanks this worked –  Deepu Feb 14 '13 at 13:58
2  
This is also mentioned in the Ubuntu LAMP setup documentation for Troubleshooting Apache‌​. There they recommend creating a file /etc/apache2/conf.d/fqdn with ServerName localhost in it –  icc97 Jun 29 '13 at 9:36
    
Very good answer - but I would also recommend putting it in the conf.d directory :) –  cwd Sep 26 '13 at 22:42
1  
/etc/apache2/conf.d/ does not exist after my install of lamp-server^ in 14.04 –  redanimalwar May 3 at 7:51
3  
For the very last step (creating sym-link in 14.04) I'd recommend sudo a2enconf fqdn though it should technically be the same. –  yoshi Jun 18 at 15:04

13.10 or newer

As of Apache 2.4 - which is available by default as of 13.10 - you cannot use the method about adding a config file in the conf.d directory.

Apache no longer uses the conf.d directory. All the configuration files are stored inside /etc/apache2/conf-available directory and all the configuration files should now have a .conf extension.

In order to solve this message in Apache 2.4, we have to create a configuration file inside the conf-available directory. For example servername.conf.

sudo vi /etc/apache2/conf-available/servername.conf

And inside this we just need to add one line

ServerName localhost

You can combine the previous two commands in one with:

echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf

If you want to use a domain name or any other name depending on the requirement its fine, just replace localhost with whatever you need. Next you have to enable this configuration. For this, you need to run the following command:

sudo a2enconf servername

a2enconf is a command to enable a configuration file in Apaches 2.4. Also note that servername on the above command is from the name of the configuration file servername.conf. If your configuration file was ngenericserver.conf then you would have to write sudo a2enconf ngenericserver.

After this reload the server and the above message will no longer bug you.

sudo service apache2 reload

or

sudo apache2ctl graceful

Now after this you will see that the message will not be shown again and the problem will be fixed.

Source: http://ngeneric.com/tutorials/linux/apache2/fix-could-not-reliably-determine-servers-fully-qualified-domain-name-error

share|improve this answer
    
Does anybody know how to make Apache say which config file it's having the problem with? I don't know why developers never think to put this in their error messages - it hardly takes much code! –  John Yeates Jul 8 at 10:08
    
If I have an Internet fqdm for this server, is this the place to put it? ie should I substitude myhost.org in place of localhost? –  CPBL Aug 14 at 16:54
1  
@CPBL This will be the default server name for all sites. If you only have one site, then that's all you need to do. If you have multiple sites on your server, you will also need to add the servername directive for each site in their respective virtual host configuration. –  Dan Oct 7 at 17:12
  • Open a terminal
  • Open the /etc/apache2/httpd.conf file:

    sudo editor /etc/apache2/httpd.conf # [1]
    
  • By default, it would be blank. Simply add the following line:

    ServerName localhost
    
  • Save the file and exit

  • Restart the server

    sudo service apache2 restart
    

[1] Launch default editor, see sudo update-alternatives --config editor

share|improve this answer
    
after executing last command the following error occur ** Restarting web server apache2 /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted) /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted) (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs Action 'start' failed. The Apache error log may have more information. [fail] ** @green7 –  Deepu Feb 14 '13 at 13:52
    
try 'sudo service apache2 restart' –  waterloo2005 Apr 15 '13 at 3:09

Apache2 can also get the FQDN from a properly configured system hostname rather than hardcoded into the apache config file. Hardcoding it will also cause confusion if the hostname changes. You actually don't need any ServerName directives in httpd.conf or any apache config files.

Put the following in /etc/hosts:

# IPv4 and IPv6 localhost aliases
127.0.0.1 hostname.domainname.com  hostname  localhost
::1       hostname.domainname.com  hostname  localhost

where hostname.domainname.com is the FQDN of your machine.

Along with a properly configured hostname in /etc/hostname/ or with hostnamectl, this will also help other services on your machine run properly (i.e. the login prompt, showing This is hostname.domainname.com instead of This is hostname.unknown_domain.)

share|improve this answer
    
+1 for "a properly configured system hostname". I wanted to configure the server properly. This also fixed my error in the log [warn] RSA server certificate CommonName (CN) <fqdn> does NOT match server name!? –  transistor1 Apr 16 at 3:21

I find it is a bit better to create a new file in /etc/conf.d that to modify either apache2.conf or httpd.conf.

It's a personal preference that keeps my configuration changes separated from the distribution package. So updates are less complicated.

I create the file /etc/apache2/conf.d/AAserverName and it contains only:

ServerName myhost.mycomain.tld

The other suggestions certainly work also.

share|improve this answer

Add ServerName localhost

To

 sudo leafpad /etc/apache2/apache2.conf

 sudo leafpad /etc/apache2/httpd.conf

It's not an error.. It's just a friend reminder

share|improve this answer

On Ubuntu 11.10, I saw this message, along with a hung boot occurring because my disk was full. One of the log files had gone rogue. Probably there was not actually a problem with Apache, but this message was the last clue given before the boot hung.

To fix the problem, I had to boot into recovery mode and remove the wayward log file.

share|improve this answer

In new version of apache2 you just following command like this:

sudo nano /etc/apache2/apache2.conf

Add the following new line end of file:

ServerName localhost

Then restart apache2:

sudo nano service apache restart

It's done.

share|improve this answer

protected by Raja Jul 5 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.