Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HP Envy 6 1002TX. I updated it to Windows 8 and now I'm having trouble installing Ubuntu 12.10. I'm not really new to Linux or Ubuntu. As suggested https://help.ubuntu.com/community/UEFI, I've tried it and it still doesn't boot. In that "Identifying if the computer boots the CD in EFI mode", I can confirm that my USB boots in EFI mode. Secure boot is disabled and my laptop has Insyde's BIOS.

I tried boot repair twice and as mentioned, here is the the pastebin link http://paste.ubuntu.com/1650182/.

Although it says I have Windows 8 installed in the MBR of /dev/sda, I remember wiping Windows 8 fully. Currently I have only one OS and that is Ubuntu 12.10. (I still regret paying $15 for Win 8 upgrade). I have tried searching for the same question or solution but haven't been able to. After I use boot-repair and it says boot .efi file from sda7/ & I do so in BIOS and this is what I get.

error: disk`,msdos5' not found grub rescue>_

share|improve this question
    
Please check: askubuntu.com/questions/221835/… –  Javier Rivera Feb 14 '13 at 14:45
    
I don't think the referenced question and answer will help, since this problem seems quite different. –  Rod Smith Feb 14 '13 at 17:25

1 Answer 1

You've got an MBR hard disk with what appears to be a set of EFI boot loaders for both Windows and Ubuntu on /dev/sda7. This is highly unusual, and most likely represent a GPT-to-MBR conversion on the disk. Some firmware implementations will boot from such a disk, and the fact that you're getting as far as GRUB suggests that yours does so; however, it's conceivable that this combination is causing GRUB to choke. It's also possible there's some more subtle problem with your partition table or GRUB configuration that I've missed.

I recommend doing one of two things:

  • Boot your installer in BIOS mode and run Boot Repair. This should install the BIOS version of GRUB on the computer, which is a more conventional choice for your MBR partition scheme and is therefore more likely to work correctly. You might need to fiddle with your firmware options to get it to attempt a BIOS-mode boot, though.
  • Download and boot Parted Magic, System Rescue CD, or a similar tool, and then run gdisk on the disk to convert it from MBR to GPT form and change the type code of partition #7 to EF00. (You should type p to verify that your partitions are all intact, type t to change the type code of partition #7, and then type w to save your changes.) With any luck this will get the computer working again; however, it's possible you'll need to run Boot Repair again.

If you try one solution and it doesn't work, you can try the other one; however, GRUB on a GPT disk booting from MBR works best if you've got a BIOS Boot Partition, so you should create one if you convert the partition table type and then install the BIOS version of GRUB.

share|improve this answer
    
I'm unable to figure out how to the first step, I'll try the second step as soon as I get time, I'm currently on tight schedule. I can't bear windows and I need my laptop. I'll try something different. I remember dual boot Ubuntu working when I had Win 7. I'll downgrade to Windows 7 and then downgrade bios. HP site still has that old bios. <I don't know if that'll work>. –  Aayush Dhuria Feb 16 '13 at 20:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.