Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following situation, I have a virtualization environment, the host is Ubuntu

Host information:

uname -a 
Linux asic 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:12:07 UTC 2012 x86_64 GNU/Linux

mii-tool
eth0: negotiated 1000baseT-FD flow-control, link ok
eth1: negotiated 1000baseT-FD flow-control, link ok
eth2: no link
eth3: no link

and when executing ethtool command also works perfectly ,

guests information:

uname -a 
Linux questa.silminds.com 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

mii-tool
SIOCGMIIPHY on 'eth0' failed: Operation not supported no MII interfaces found

ethtool

Settings for eth0:
No data available

and when i try to set the network card interface settings using

 ethtool -s etho speed 1000 duplex full 
 Cannot get current device settings: No such device
  not setting speed
  not setting duplex

some details :

host is ubuntu 10.04 LTS
kvm version is version 0.12.3 (qemu-kvm-0.12.3)

share|improve this question
add comment

1 Answer 1

Not sure what the problem you're trying to resolve is, but this looks like part of your problem:

ethtool -s etho speed 1000 duplex full
              ^
              |
           eth0

Zero =/= 'oh'

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.