Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I purchased a new Dell 15R laptop which came with pre installed windows 8 64 bit and ueifi boot. I made a ubuntu 12.10 dvd and loaded it. When i started installing my installer could not recognise any other windows 8 or any other OS installed. When i moved to advanced partition tool, i could see my free space, my windows partitions. But i did not proceed. can anyone help.

share|improve this question

I had a similar problem with my Dell XPS 8500 desktop. I found the following bug report helpful:

The workaround suggested there worked for me. Run ubiquity (the Ubuntu installer) with the following command:

$ WINOSDATA=true ubiquity

Slightly more detailed instructions, if they are needed:

  1. Boot your computer from the Ubuntu Live CD (or USB), and select the option "Try Ubuntu without installing".

  2. Open a terminal window, e.g. by pressing Ctrl+ALt+T.

  3. Enter the command $ WINOSDATA=true ubiquity

The Ubuntu installer should then detect your Windows 8 installation (it did for me).

The problem appears to be with os-prober, the command used by ubiquity to detect installed operating systems. You can test this by running first $ sudo os-prober, and then $ sudo WINOSDATA=true os-prober. You may find that in the first case, no OS is detected, but in the second, Windows 8 is detected. (Substituting any non-zero value for "true" works equally well. Don't ask me why.)

share|improve this answer
Thanks ill try and report back – user1150593 Feb 14 '13 at 10:59
This worked perfectly in my case - thanks a lot! – Bachi Mar 15 '13 at 11:38

Yes, go to the boot options when the machine starts and disable the UEFI!

share|improve this answer
Thanks ill try and report back – user1150593 Feb 14 '13 at 11:00

I had a similar problem with my laptop that came with Windows 8. It turned out there were both GPT and MBR partition tables, which was confusing the installed (and gparted). Follow these steps:

Boot Live CD, don't choose the install option, choose test out Ubuntu.

Open a shell and type

sudo sgdisk --zap /dev/sda

Where sda is the disk with the Windows partition. It'll complain about partition problems, but this is ok.

Proceed with your Ubuntu installation.

source here

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Braiam Aug 11 '13 at 22:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.