Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cant install wine. Cant do anything with this.

 sudo aptitude install wine1.5
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasyncns0:i386{a} libavahi-client3:i386{a} 
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libc6:i386{a} libcapi20-3{a} 
  libcapi20-3:i386{a} libcomerr2:i386{a} libcups2:i386{a} libdb5.1:i386{a} libdbus-1-3:i386{a} 
  libdrm-intel1:i386{ab} libdrm-nouveau1a:i386{ab} libdrm-radeon1:i386{ab} libdrm2:i386{ab} 
  libexif12:i386{a} libexpat1:i386{a} libffi6:i386{a} libflac8:i386{a} libfontconfig1:i386{a} 
  libfreetype6:i386{a} libgcc1:i386{a} libgcrypt11:i386{a} libgd2-xpm:i386{a} libgif4:i386{a} 
  libgl1-mesa-dri:i386{ab} libgl1-mesa-glx:i386{ab} libglapi-mesa:i386{ab} libglib2.0-0:i386{a} 
  libglu1-mesa:i386{a} libgnutls26:i386{a} libgpg-error0:i386{a} libgphoto2-2:i386{a} 
  libgphoto2-port0:i386{a} libgpm2:i386{a} libgssapi-krb5-2:i386{a} libgssapi3-heimdal:i386{a} 
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} 
  libice6:i386{a} libieee1284-3:i386{a} libjpeg-turbo8:i386{a} libjpeg8:i386{a} libjson0:i386{a} 
  libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} 
  libkrb5support0:i386{a} liblcms1:i386{a} libldap-2.4-2:i386{a} libllvm3.0:i386{a} 
  libltdl7:i386{a} libmpg123-0:i386{a} libncurses5:i386{a} libodbc1{a} libogg0:i386{a} 
  libopenal1:i386{a} liborc-0.4-0:i386{a} libosmesa6:i386{a} libp11-kit0:i386{a} 
  libpam-winbind{a} libpciaccess0:i386{a} libpcre3:i386{a} libpng12-0:i386{a} libpulse0:i386{a} 
  libroken18-heimdal:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} 
  libselinux1:i386{a} libsm6:i386{a} libsndfile1:i386{a} libsqlite3-0:i386{a} libssl1.0.0:i386{a} 
  libstdc++6:i386{ab} libtasn1-3:i386{a} libtiff4:i386{a} libtinfo5:i386{a} libusb-0.1-4:i386{a} 
  libuuid1:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libvorbis0a:i386{a} 
  libvorbisenc2:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} libx11-6:i386{a} 
  libx11-xcb1:i386{a} libxau6:i386{a} libxcb-glx0:i386{a} libxcb1:i386{a} libxcomposite1:i386{a} 
  libxcursor1:i386{a} libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} 
  libxi6:i386{a} libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a} 
  libxrender1:i386{a} libxslt1.1:i386{a} libxt6:i386{a} libxxf86vm1:i386{a} ttf-umefont{a} 
  ttf-unfonts-core{a} unixodbc{a} winbind{a} wine-gecko1.9{a} wine-gecko1.9:i386{a} 
  wine-mono0.0.8{a} wine1.5 wine1.5-amd64{a} wine1.5-i386:i386{a} winetricks{a} zlib1g:i386{a} 
0 packages upgraded, 125 newly installed, 0 to remove and 0 not upgraded.
Need to get 173 MB of archives. After unpacking 452 MB will be used.
The following packages have unmet dependencies:
 libstdc++6 : Breaks: libstdc++6:i386 (!= 4.7.2-11precise2) but 4.6.3-1ubuntu5 is to be installed.
 libstdc++6:i386 : Breaks: libstdc++6 (!= 4.6.3-1ubuntu5) but 4.7.2-11precise2 is installed.
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.39-0ubuntu1) but 2.4.39-0ubuntu0.1 is to be installed.
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1 is installed.
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 9.0-0ubuntu1) but 8.0.4-0ubuntu0.3 is to be installed.
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 8.0.4-0ubuntu0.3) but 9.0-0ubuntu1 is installed.
 libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 9.0-0ubuntu1) but 8.0.4-0ubuntu0.3 is to be installed.
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.4-0ubuntu0.3) but 9.0-0ubuntu1 is installed.
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 9.0-0ubuntu1) but 8.0.4-0ubuntu0.3 is to be installed.
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 8.0.4-0ubuntu0.3) but 9.0-0ubuntu1 is installed.
 libdrm2 : Breaks: libdrm2:i386 (!= 2.4.39-0ubuntu1) but 2.4.39-0ubuntu0.1 is to be installed.
 libdrm2:i386 : Breaks: libdrm2 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1 is installed.
 libdrm-nouveau1a : Breaks: libdrm-nouveau1a:i386 (!= 2.4.39-0ubuntu1) but 2.4.39-0ubuntu0.1 is to be installed.
 libdrm-nouveau1a:i386 : Breaks: libdrm-nouveau1a (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1 is installed.
 libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.39-0ubuntu1) but 2.4.39-0ubuntu0.1 is to be installed.
 libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.39-0ubuntu0.1) but 2.4.39-0ubuntu1 is installed.
Internal error: the solver Install(wine1.5:i386 1.5.23-0ubuntu1 <wine1.5-amd64:amd64 1.5.23-0ubuntu1 -> {wine1.5:amd64 1.5.23-0ubuntu1 wine1.5:i386 1.5.23-0ubuntu1}>) of a supposedly unresolved dependency is already installed in step 18
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.9:i386 1.9-0ubuntu1~ppa1~precise1 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 411
open: 135; closed: 364; defer: 109; conflict: 202                                                    .The following actions will resolve these dependencies:

       Keep the following packages at their current version:                     
1)       libasn1-8-heimdal:i386 [Not Installed]                                  
2)       libasound2:i386 [Not Installed]                                         
3)       libasyncns0:i386 [Not Installed]                                        
4)       libavahi-client3:i386 [Not Installed]                                   
5)       libavahi-common3:i386 [Not Installed]                                   
6)       libc6:i386 [Not Installed]                                              
7)       libcapi20-3:i386 [Not Installed]                                        
8)       libcomerr2:i386 [Not Installed]                                         
9)       libcups2:i386 [Not Installed]                                           
10)      libdb5.1:i386 [Not Installed]                                           
11)      libdbus-1-3:i386 [Not Installed]                                        
12)      libdrm-intel1:i386 [Not Installed]                                      
13)      libdrm-nouveau1a:i386 [Not Installed]                                   
14)      libdrm-radeon1:i386 [Not Installed]                                     
15)      libdrm2:i386 [Not Installed]                                            
16)      libexif12:i386 [Not Installed]                                          
17)      libexpat1:i386 [Not Installed]                                          
18)      libffi6:i386 [Not Installed]                                            
19)      libflac8:i386 [Not Installed]                                           
20)      libfontconfig1:i386 [Not Installed]                                     
21)      libfreetype6:i386 [Not Installed]                                       
22)      libgcc1:i386 [Not Installed]                                            
23)      libgcrypt11:i386 [Not Installed]                                        
24)      libgd2-xpm:i386 [Not Installed]                                         
25)      libgif4:i386 [Not Installed]                                            
26)      libgl1-mesa-dri:i386 [Not Installed]                                    
27)      libgl1-mesa-glx:i386 [Not Installed]                                    
28)      libglapi-mesa:i386 [Not Installed]                                      
29)      libglib2.0-0:i386 [Not Installed]                                       
30)      libglu1-mesa:i386 [Not Installed]                                       
31)      libgnutls26:i386 [Not Installed]                                        
32)      libgpg-error0:i386 [Not Installed]                                      
33)      libgphoto2-2:i386 [Not Installed]                                       
34)      libgphoto2-port0:i386 [Not Installed]                                   
35)      libgpm2:i386 [Not Installed]                                            
36)      libgssapi-krb5-2:i386 [Not Installed]                                   
37)      libgssapi3-heimdal:i386 [Not Installed]                                 
38)      libgstreamer-plugins-base0.10-0:i386 [Not Installed]                    
39)      libgstreamer0.10-0:i386 [Not Installed]                                 
40)      libhcrypto4-heimdal:i386 [Not Installed]                                
41)      libheimbase1-heimdal:i386 [Not Installed]                               
42)      libheimntlm0-heimdal:i386 [Not Installed]                               
43)      libhx509-5-heimdal:i386 [Not Installed]                                 
44)      libice6:i386 [Not Installed]                                            
45)      libieee1284-3:i386 [Not Installed]                                      
46)      libjpeg-turbo8:i386 [Not Installed]                                     
47)      libjpeg8:i386 [Not Installed]                                           
48)      libjson0:i386 [Not Installed]                                           
49)      libk5crypto3:i386 [Not Installed]                                       
50)      libkeyutils1:i386 [Not Installed]                                       
51)      libkrb5-26-heimdal:i386 [Not Installed]                                 
52)      libkrb5-3:i386 [Not Installed]                                          
53)      libkrb5support0:i386 [Not Installed]                                    
54)      liblcms1:i386 [Not Installed]                                           
55)      libldap-2.4-2:i386 [Not Installed]                                      
56)      libllvm3.0:i386 [Not Installed]                                         
57)      libltdl7:i386 [Not Installed]                                           
58)      libmpg123-0:i386 [Not Installed]                                        
59)      libncurses5:i386 [Not Installed]                                        
60)      libogg0:i386 [Not Installed]                                            
61)      libopenal1:i386 [Not Installed]                                         
62)      liborc-0.4-0:i386 [Not Installed]                                       
63)      libosmesa6:i386 [Not Installed]                                         
64)      libp11-kit0:i386 [Not Installed]                                        
65)      libpciaccess0:i386 [Not Installed]                                      
66)      libpcre3:i386 [Not Installed]                                           
67)      libpng12-0:i386 [Not Installed]                                         
68)      libpulse0:i386 [Not Installed]                                          
69)      libroken18-heimdal:i386 [Not Installed]                                 
70)      libsane:i386 [Not Installed]                                            
71)      libsasl2-2:i386 [Not Installed]                                         
72)      libsasl2-modules:i386 [Not Installed]                                   
73)      libselinux1:i386 [Not Installed]                                        
74)      libsm6:i386 [Not Installed]                                             
75)      libsndfile1:i386 [Not Installed]                                        
76)      libsqlite3-0:i386 [Not Installed]                                       
77)      libssl1.0.0:i386 [Not Installed]                                        
78)      libstdc++6:i386 [Not Installed]                                         
79)      libtasn1-3:i386 [Not Installed]                                         
80)      libtiff4:i386 [Not Installed]                                           
81)      libtinfo5:i386 [Not Installed]                                          
82)      libusb-0.1-4:i386 [Not Installed]                                       
83)      libuuid1:i386 [Not Installed]                                           
84)      libv4l-0:i386 [Not Installed]                                           
85)      libv4lconvert0:i386 [Not Installed]                                     
86)      libvorbis0a:i386 [Not Installed]                                        
87)      libvorbisenc2:i386 [Not Installed]                                      
88)      libwind0-heimdal:i386 [Not Installed]                                   
89)      libwrap0:i386 [Not Installed]                                           
90)      libx11-6:i386 [Not Installed]                                           
91)      libx11-xcb1:i386 [Not Installed]                                        
92)      libxau6:i386 [Not Installed]                                            
93)      libxcb-glx0:i386 [Not Installed]                                        
94)      libxcb1:i386 [Not Installed]                                            
95)      libxcomposite1:i386 [Not Installed]                                     
96)      libxcursor1:i386 [Not Installed]                                        
97)      libxdamage1:i386 [Not Installed]                                        
98)      libxdmcp6:i386 [Not Installed]                                          
99)      libxext6:i386 [Not Installed]                                           
100)     libxfixes3:i386 [Not Installed]                                         
101)     libxi6:i386 [Not Installed]                                             
102)     libxinerama1:i386 [Not Installed]                                       
103)     libxml2:i386 [Not Installed]                                            
104)     libxpm4:i386 [Not Installed]                                            
105)     libxrandr2:i386 [Not Installed]                                         
106)     libxrender1:i386 [Not Installed]                                        
107)     libxslt1.1:i386 [Not Installed]                                         
108)     libxt6:i386 [Not Installed]                                             
109)     libxxf86vm1:i386 [Not Installed]                                        
110)     wine-gecko1.9:i386 [Not Installed]                                      
111)     wine1.5 [Not Installed]                                                 
112)     wine1.5-amd64 [Not Installed]                                           
113)     wine1.5-i386:i386 [Not Installed]                                       
114)     zlib1g:i386 [Not Installed]                                             

       Leave the following dependencies unresolved:                              
115)     libncurses5:i386 recommends libgpm2:i386                                
116)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386 (>= 7.2)           
117)     libgphoto2-2:i386 recommends udev:i386 (>= 0.175)                       
118)     libgphoto2-2:i386 recommends libgphoto2-l10n:i386 (>= 2.4.13-1ubuntu1.2)
119)     winetricks recommends wine1.5 | wine1.4 | wine | cxoffice5 | cxgames5   
120)     wine-mono0.0.8 recommends wine1.5                                       
121)     wine-gecko1.9 recommends wine1.5-amd64                                  
122)     wine1.5-i386:i386 recommends libsane:i386                               
123)     wine-gecko1.9:i386 recommends wine1.5-i386:i386                         


Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
share|improve this question
    
I don't think this is really a typical unmet dependencies problem. This seems like a combination of using aptitude where apt-get should be used (because the aptitude multiarch bug is only fixed in 12.10), and the proper software source for wine1.5 not being enabled (see my answer and its comments). I recommend we reopen this. –  Eliah Kagan Feb 15 '13 at 0:04
    
The contents of your /etc/apt/sources.list and output of apt-get update would be useful. It looks like you have a combination of precise and quantal versions there. –  wgrant Feb 15 '13 at 9:57

3 Answers 3

Make sure you have added the PPA.

sudo add-apt-repository ppa:ubuntu-wine/ppa

Then update your system.

sudo apt-get update

Then try installing Wine 1.5

sudo apt-get install wine1.5

That should get you up and running.

References

Adding the WineHQ PPA Repository

share|improve this answer

I aslo face similar issue on Ubuntu 12.04, I uses some step which i suggest here but before that you should try remove any instance of wine using following

  1. use command to see list of particular package is installed sudo dpkg --list | grep wine

    it displayed list of preinstalled wine instance, if any

  2. Remove the package which result in step first for e.g. if list like ii wine1.5 1.5.23-0ubuntu1 Microsoft Windows Compatibility Layer (Binary Emulator and Library) ii wine1.5-i386 1.5.23-0ubuntu1 Microsoft Windows Compatibility Layer (32-bit support) ii winetricks

use command following commnd to remove wine1.5, wine1.5-i386 as sudo apt-get remove --purge wine1.5 sudo apt-get remove --purge wine1.5-i386 or sudo apt-get remove --purge wine*

  • to remove additional supporting file if not completely removed by purge command sudo apt-get remove --auto-remove wine1.5 and sudo apt-get remove --auto-remove wine1.5i386 && sudo apt-get autoclean

Referance: Read article for remove package

Try to add new architecture i386, use sudo dpkg --add-architecture i386 &&sudo apt-get update

Add latest repositery of wine sudo add-apt-repository ppa:ubuntu-wine/ppa &&sudo apt-get update Finaly run sudo apt-get install wine1.5

Also check following link for similar solution.... similar solution Other Similar Problem Solution

share|improve this answer
    
wine is not installed. Architecture i386 added. PPA also added before. Not working. I tried ppa-purge, then re-added. –  g1ra Feb 14 '13 at 13:11

aptitude has a bug that keeps it from handling multiarch properly. So if you use apt-get instead, that may fix the problem. (And of course make sure to update before performing any major package management action from the command-line, unless you've done so recently.)

sudo apt-get update
sudo apt-get install wine1.5

The bug was fixed in Ubuntu 12.10, but it has not been fixed in 12.04 or 11.10.

If apt-get says wine1.5 is not available:

If you don't specifically need version 1.5 of Wine, just install the latest version available in the official Ubuntu repositories:

sudo apt-get update
sudo apt-get install wine

If you do specifically need Wine 1.5, and you're running Ubuntu 11.10 or later (which it appears you are), enable the Wine PPA by running:

sudo add-apt-repository ppa:ubuntu-wine/ppa

(Or you can use this graphical method.)

Then you should be able to install Wine 1.5:

sudo apt-get update
sudo apt-get install wine1.5

Please note that, after adding the PPA with add-apt-repository, you must run sudo apt-get update for the package manager to know to consult the newly added software source.

If that doesn't work:

If it still says Package wine1.5 is not available, but is referred to by another package., then it will be necessary to gather more information on what software sources are available. So run these commands, then put the output (separately) in your question:

cat /etc/apt/sources.list
for X in /etc/apt/sources.list.d/*; do echo; echo; echo "** $X:"; echo; cat $X; done
share|improve this answer
    
sudo apt-get install wine1.5 Reading package lists... Done Building dependency tree Reading state information... Done Package wine1.5 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'wine1.5' has no installation candidate –  g1ra Feb 14 '13 at 23:51
    
@g1ra I've expanded my answer; please let me know if it helps (or if not, what happens). –  Eliah Kagan Feb 15 '13 at 0:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.