Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
~$ lspci | grep Network
06:00.0 Network controller: Intel Corporation WiMAX/WiFi Link 5150

~$ rfkill list all
 0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
 1: i2400m-usb:1-1.1:1.0: WiMAX
Soft blocked: yes
Hard blocked: no
 2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

~$ sudo rfkill unblock all

But WiFi is still disabled. Here is some info:

~$ sudo lshw -class network
  *-network DISABLED      
        description: Wireless interface
        product: WiMAX/WiFi Link 5150
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:06:00.0
   logical name: wlan0
   version: 00
   serial: 00:16:eb:2b:1d:90
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-37-generic firmware=8.24.2.2 latency=0 link=no multicast=yes wireless=IEEE 802.11abg

I tried also:

  1. Default all BIOS settings.
  2. Removing the battery.

It worked couple of days ago, but now I really don't know what to do. Can someone help me?

UPDATE:

~$ dmesg | grep iwl
[   14.184885] iwlwifi 0000:06:00.0: found PCI INT A -> IRQ 10
[   14.184885] iwlwifi 0000:06:00.0: sharing IRQ 10 with 0000:00:1c.0
[   14.184885] iwlwifi 0000:06:00.0: sharing IRQ 10 with 0000:00:1c.4
[   14.184885] iwlwifi 0000:06:00.0: sharing IRQ 10 with 0000:01:00.1
[   14.184885] iwlwifi 0000:06:00.0: setting latency timer to 64
[   14.184885] iwlwifi 0000:06:00.0: pci_resource_len = 0x00002000
[   14.184885] iwlwifi 0000:06:00.0: pci_resource_base = ffffc90002184000
[   14.184885] iwlwifi 0000:06:00.0: HW Revision ID = 0x0
[   14.184885] iwlwifi 0000:06:00.0: irq 19 for MSI/MSI-X
[   14.184885] iwlwifi 0000:06:00.0: Detected Intel(R) WiMAX/WiFi Link 5150 ABG, REV=0x44
[   14.184885] iwlwifi 0000:06:00.0: L1 Disabled; Enabling L0S
[   14.204887] iwlwifi 0000:06:00.0: device EEPROM VER=0x223, CALIB=0x4
[   14.204887] iwlwifi 0000:06:00.0: Device SKU: 0Xb0
[   14.204887] iwlwifi 0000:06:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[   15.048939] iwlwifi 0000:06:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[   15.048939] iwlwifi 0000:06:00.0: RF_KILL bit toggled to disable radio.
[   15.104943] iwlwifi 0000:06:00.0: loaded firmware version 8.24.2.2

Here is modules:

~$ lsmod
Module                  Size  Used by
vesafb                 13844  1 
joydev                 17693  0 
ums_realtek            18248  0 
snd_hda_codec_hdmi     32474  4 
uas                    18180  0 
arc4                   12529  2 
nvidia              12319264  52 
i2400m_usb             36569  0 
i2400m                108026  1 i2400m_usb
wimax                  34762  1 i2400m
rfcomm                 47604  12 
bnep                   18281  2 
parport_pc             32866  0 
ppdev                  17113  0 
binfmt_misc            17540  1 
snd_hda_codec_conexant    62358  1 
snd_hda_intel          33773  7 
snd_hda_codec         127706  3             snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep              17764  1 snd_hda_codec
snd_pcm                97275  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
uvcvideo               72627  0 
videodev               98259  1 uvcvideo
v4l2_compat_ioctl32    17128  1 videodev
btusb                  18332  2 
bluetooth             180153  23 rfcomm,bnep,btusb
psmouse                97485  0 
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
mac_hid                13253  0 
serio_raw              13211  0 
iwlwifi               397059  0 
mac80211              506862  1 iwlwifi
cfg80211              205774  2 iwlwifi,mac80211
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29990  3 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    79041  22     snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
mei                    41616  0 
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
usb_storage            49198  1 ums_realtek
usbhid                 47238  0 
hid                    99636  1 usbhid
r8169                  62154  0
share|improve this question
    
Have you tried pressing Fn-F(something), where F(something) is the key with a tiny symbol of antenna? Most laptops have either that, or a dedicated wifi button. –  Sergey Feb 14 '13 at 5:55
    
Yeah, I tried Fn+F6 (F6 is a wireless switcher) - still the same. And one more thing - I have a physical switcher on my laptop, but its not working too. –  MikeRat Feb 14 '13 at 6:11
    
@Rinzwind I found this in lsmod - wimax 34762 1 i2400m and iwlwifi 397059 0. Checked dmesg | grep iwl - no notices like unsupported, please see update in question. –  MikeRat Feb 14 '13 at 10:10
    
It must be something really stupidly simple but I am not seeing it :X sorry. It all looks ok to me. –  Rinzwind Feb 14 '13 at 10:34
    
@Rinzwind Yup, and this is the main problem... –  MikeRat Feb 14 '13 at 11:20

1 Answer 1

This issue related to the in-efficency of wifi linux driver . If you have another operating system (such as windows 7,8 ..) log in to that operating system and turn the wifi switch on using fn + F6 . After enabling wifi adapter in windows , reboot the system and log into ubuntu . Then you can use the wifi functionality.

Cheers Ubuntu geek

share|improve this answer
    
Thank you for reply, but I installed only Ubuntu. Is there any other solutions I can try? Or I should install Windows as dual boot and nothing else will help me solve this case? –  MikeRat Feb 14 '13 at 9:16
    
Please try loading a module: sudo modprobe ideapad-laptop. Now try the switch. Also try: sudo rfkill unblock all. If that helps, and there are no other negative consequences, we can add it to /etc/modules so it loads automatically on boot. –  chili555 Feb 14 '13 at 15:56
    
Did you check the BIOS settings for enabling wifi adapter ? –  ubuntu_geek Feb 15 '13 at 4:30
    
@chili555 Tried, unfortunately its not working. –  MikeRat Feb 15 '13 at 5:19
    
@ubuntu_geek Yeah, adapter is enabled in BIOS. –  MikeRat Feb 15 '13 at 5:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.