Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I replaced my graphics card but I'm not sure how to set things up on Ubuntu.

When the computer boots, it doesn't start GDM (I think that's what it's called). Instead, it asks me to log in the command line. If I try to do a startx, it tells me there is no AMD device connected or something to that extent.

I originally installed the ATI drivers using the GUI. It said that I was using the limited drivers or something to that extent with a popup on the right of one of the taskbars, so I clicked there and updated it. I think it could also be reached by going to System > Administration > Restricted drivers or something close to that.

I tried installing the nivida drivers by doing a sudo apt-get install nvidia-glx-185 and then doing sudo modprobe nvidia and sudo nvidia-xconfig as this guy says but that didn't work.

modprobe couldn't find anything related to Nvidia and nvidia-xconfig wasn't an available command for me. Since I wasn't sure how to remove the ATI drivers I did that without messing with them. Not sure if that was a good idea.

share|improve this question
Try using jockey from the command line to uninstall one and install the other:… – Jorge Castro Feb 9 '11 at 20:25
up vote 5 down vote accepted

There is also a command line version of the restricted drivers manager, which you can run via this command:


(The GUI version is jockey-gtk... both programs use the same backend). It picks the best driver for you, and also sets up your /etc/X11/xorg.conf with the recommended defaults for the driver with your hardware.

Note that if you download the driver from the NVIDIA website, that is not the version of the driver supported in Ubuntu and could lead to other issues such as upgrade problems, so you're on your own if you do that. It's a lot better to use the driver packaged with Ubuntu.

If you want a newer driver than the one that comes with Ubuntu, we also provide an 'x-updates' PPA where we put packaged versions of the upstream NVIDIA driver for users. These updated drivers are lightly tested by us and will work with the packaging system so you won't have the troubles you might if you manually install them.

You should be able to add this PPA, and then upgrade and it will pull in newer drivers as they're available.

Also note that the nvidia-glx-185 driver is particular to an older version of Ubuntu. We no longer name the drivers that way; the latest and greatest driver will always be installable by the nvidia-graphics-drivers package name. There are several legacy drivers available as well. If you have an older nvidia card you might find one of these supports your hardware better. But it's best to just run jockey-text or jockey-gtk and let it look up the right driver for your card, and not worry all of this.

Finally, for anyone who happens to be running the development version of Ubuntu, note that sometimes the proprietary drivers are broken during development, because when we update the kernel and xserver these drivers have to be rebuilt by AMD and NVIDIA to match, and this can take a few months before we get fixed drivers from them.

share|improve this answer

I didn't download the .run from NVidia's page because that seemed to be what the apt-get install nvidia-glx-185 does.

I tried using jockey-text BUT it didn't report the ati driver as installed to me. It showed NVidia's recently installed driver however. It was also inactive.

So here it explains how to remove ATI's proprietary drivers to install... either ATI's drivers again or the free/open source alternative or something like that. Well, here's the necessary step:

sudo apt-get remove --purge xorg-driver-fglrx fglrx*

Then I removed the nvidia-glx-185 I had installed previously and installed all the nvidia-185 packages. I used 185 but there seems to be a current that might be more appropriate. Anyway:

sudo apt-get install nvidia-185-*


sudo apt-get install nvidia-current-*

You also have to install nvidia-glx. This one doesn't have a current so you have to tab to see the newest. In my case it was 185, so:

sudo apt-get install nvidia-glx-185

After that:

sudo nvidia-xconfig

And it worked.


sudo apt-get remove --purge xorg-driver-fglrx fglrx*
sudo apt-get install nvidia-glx-185
sudo apt-get install nvidia-current-*
sudo nvidia-xconfig

I suspect the inverse (uninstalling nvidia and installing ATI's) is more complicated since installing ATI's drivers from the command line is always problematic for me.

share|improve this answer

Try to install NVIDIA proprietary drivers. Download them from Nvidia's page. After downloading the file (, at the time of writing this), do this from the command line:

sudo sh

(if you can't download it from other computer, try wget )

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.