Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a hard time installing the Nvidia drivers on my Dell XPS l502x. Specs: Intel core i5 (2nd gen) 8GB RAM Nvidia GeForce GT 525M/ also has integrated Intel graphics as well Running Ubuntu 12.04 lts

When I install nvidia-current from software center and try to go to the nvidia settings,i get the following message: You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just runnvidia-xconfigas root), and restart the X server

How can I fix this because I want to try running unity 3d. I did a lot of searching and tried all of the suggestions out there but nothing worked. I know my graphics card is supported in the nvidia-current driver from the software center because it is listed in the /usr/share/doc/nvidia-current/README.txt.gz. Any help is appreciated.

share|improve this question
add comment

1 Answer

After installing the nvidia driver you need to re-start X. Log out and back in.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.