Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a few unsuccessful installation attempts I finally found this guide that looked all set to solve all my problems. After following it however - reinstalling and doing the "Repair the boot image after reinstallation" bit by recreating /etc/crypttab later, I now have the following situation:

I boot up and get the login screen, where I enter my password and get a breif flash of the following text:

Starting crash report submission
checking battery state
Stopping System V runlevel compatibility
Plymouth command failed mountall: Disconnecting from Plymouth

I hope I got it right, had to type in my password about 15 times to read it, it flashes so quickly, and then just returns to the login screen.

I am able to log in as guest, but that is not very helpful I find.

I am able to do Ctrl+Alt+F1 and log in tty1. So clearly I have the password right :)

I must admit, in one of my previous attempts at reinstallation I did use a different password, which may have encrypted (the already encrypted?) \home, which might have something to do with this mess.

I don't know if this is helpful, but in tty1 i did


and my password was correct ie I get the hex code for dm-2, which I believe is where my /home is.

I'm at my wits end, any help will be greatly appreciated!

UPDATE: OK, so I've made some progress: I used a live usb to get back 'in', then ran lvm2 to mount the disk, which showed me two users! One was my original one, and the second was one I set up in one of my failed reinstalls. Both /homes encrypted of course :). I then did (from here):


And the first encrypted partition that showed up was the second one, for which no password worked:(

But it prompts me "do you know the password", so I was honest and said NO. Then it asked me for the 32 digit hex passphrase. And I had something similar written on a piece of paper - don't ask me at what point in my previous cock-up-installs I had the foresight to write it down and it worked!

Then it found the second encrypted partition (or rather logical volume), which was my original one, for which I knew the password. Hooray, so it mounted both in /tmp.

This is all great, I can now backup the nonessential stuff I wasn't too worried about.

But is there a solution that doesn't involve me reinstalling clean? It seems like I have the same /home logical partition double encrypted or some weird thing like that. Can I get rid of the second user somehow from live ubuntu?

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.