Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I could run Notepad++ easily but I fail to run the Angry bird exe. Whenever I open the exe, I see one of my screen flickrs a bit (as lines and not the whole screen) and nothing happens. Any ideas?

Edit: Output of wine angrybirds.exe

fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.4053)
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC90.CRT" (9.0.21022.8)
err:module:import_dll Library MSVCP90.dll (which is needed by L"C:\\windows\\system32\\AppUpWrapper.dll") not found
err:module:import_dll Library AppUpWrapper.dll (which is needed by L"C:\\windows\\system32\\angrybirds.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\angrybirds.exe" failed, status c0000135

I think it didn't even install. I manually dropped those files in the folder but still no gain.

Edit: Progress

I dropped the file MSVCP90.dll manually and now this is what I get in the output

fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.4053)
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC90.CRT" (9.0.21022.8)
fixme:heap:HeapSetInformation 0x541000 0 0x32fd48 4
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
EXCEPTION: Failed to open data/scripts/starLimits.lua
wine: Unhandled exception 0x40000015 at address 0x7b880023:0x78b271d0 (thread 0009), starting debugger...
fixme:msvcr90:__clean_type_info_names_internal (0x10267694) stub
fixme:msvcr90:__clean_type_info_names_internal (0x78506644) stub
ashfame@ashfame-desktop:~$ Process of pid=0008 has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
0000000e services.exe
    00000014    0
    00000010    0
    0000000f    0
00000011 winedevice.exe
    00000018    0
    00000016    0
    00000013    0
    00000012    0
00000019 explorer.exe
    0000001a    0
You must be attached to a process to run this command.
No process loaded, cannot execute 'detach'

and there the terminal hangs (I mean I would have to Ctrl + C to get out). It shows up the famous message, that it needs to close down.

Edit: Just to let you know that I am still stuck at it. I don't use wine for anything else, so I am ready to do a clean install of wine and everything if anyone is willing to provide me instructions.

Resolved

As per the marked correct answer by @DoR, I did a mv ~/.wine ~/wine.bak and then re-ran the game and it worked. So basically it was something wrong in the wine install. :)

share|improve this question
    
can you add the output of wine angrybirds.exe | output.txt? –  RolandiXor Feb 9 '11 at 16:26
    
@Roland Please check the output –  Ashfame Feb 10 '11 at 16:43
    
You may still be missing dlls, such as MVC8, maybe a dependency checker might be able to find the missing dlls (sorry I forgot the name of the most popular one that works on wine). –  RolandiXor Feb 11 '11 at 4:38
    
@Roland So what can I do for a clean and stable wine setup? –  Ashfame Feb 11 '11 at 20:45
2  
the problem is not a clean and stable wine setup here, though that might help. WINE misses a lot of dlls, not sure why, but it it does. What you can do is delete ~/.wine (NB: YOU WILL LOSE ALL WINE APPLICATIONS SHOULD YOU DO THIS) and start from scratch, or you could install vineyard and use it to create a new wine bottle. –  RolandiXor Feb 11 '11 at 22:20
add comment

4 Answers

up vote 5 down vote accepted
  1. Add the PPA for Ubuntu Wine Team:

    sudo add-apt-repository ppa:ubuntu-wine/ppa
    
  2. Install the wine1.3Install wine1.3 package. Just running Update Manager won't install it as it is a different package than wine1.2Install wine1.2 (the version of Wine included in the repositories).

    sudo apt-get update
    sudo apt-get install wine1.3  
    
  3. Double-click on AngryBirds.exe or in a terminal run the command:

    wine AngryBirds.exe
    

    If this still doesn't work, try backing up and removing your ~/.wine directory:

    mv ~/.wine ~/.wine.bak
    
  4. Kill some green pigs:

    enter image description here

share|improve this answer
    
@DoR How do I completely remove it first? I installed the one from repositories so I think its 1.2 –  Ashfame Mar 2 '11 at 17:38
    
@Ashfame, sudo apt-get remove wine1.2? I already had the wine from the repositories installed when I install wine1.3 and I didn't need to remove it. –  Alvin Row Mar 2 '11 at 17:42
    
@DoR Sadly that didn't work. I am having the same errors with wine AngryBirds.exe as I have in my question along with a few more. –  Ashfame Mar 2 '11 at 18:44
    
@Ashfame What does wine --version say? –  Alvin Row Mar 2 '11 at 19:28
    
@DoR wine-1.3.14 –  Ashfame Mar 2 '11 at 19:46
show 9 more comments

Try adding the wine ppa (ppa:ubuntu-wine/ppa) to your software sources and upgrade wine to the latest version. This should make Angry Birds work well.

share|improve this answer
    
I have them added and already did a sudo apt-get update –  Ashfame Feb 9 '11 at 17:13
add comment

I had same troble. Solved it very easely: when you install "Angry birds" just check Microsoft Visual C++ redistribitible package

share|improve this answer
add comment

This error may occur when missing "Microsoft Visual C++ Redistributable Package". To fix it

  1. Identify the version that you need to install from ' L"Microsoft.VC80.CRT" (8.0.50727.4053) ' (brackets containing version)
  2. Pick correct version from here to download.
  3. Then just download it and install using wine.

    You will see the success!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.