Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Android SDK in my Eclipse EE IDE. Now I'm trying to open the Android SDK manager but getting error as in following image

Even I tried to see the android console as shown in image, No error shows in console. [is LogCat console for Android? I searched error for as android console].

Thank you

share|improve this question
Having same problem :( – Mayu Mayooresan Jun 7 '13 at 8:31
I reinstalled the Eclipse and android SDK. now it's working perfectly. – Silambarasan Jun 12 '13 at 4:57

try this

chmod -R uga+rwx <android-sdk-folder>
share|improve this answer
great answer...+1 – CapDroid Dec 21 '13 at 10:35

This error occurs when the Ubuntu user logged in doesn't have access to the folder in which the Android SDK files are located.

Make sure to open nautilus and set permissions accordingly and give permissions to read/write/execute.

I did that and it worked like magic.

share|improve this answer

try this:

chmod +x <ADTFolder>/sdk/tools/android
share|improve this answer
comfort at last...... thanks! – rafi Sep 10 '13 at 6:16
  1. Go to tools folder in "sdk"

  2. In the "tools" folder available "android" file then go to the properties of the file in that click permission(at the top).

  3. Check "Allow executing file as a program"(bottom left) then close that

  4. Then run sdk it works, if it is not work copy your sdk file into your Home and set the path

  5. Imp: you should check if your sdk tools and platform-tools path is set.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.