Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to run wubi on Windows XP Professional 5.1 (Build 2600.xpsp_sp3_gdr.120821-1629: SP 3)

I have Administrator rights

I downloaded wubi from here

I have installed Python 3.2 and my PATH is set as

C:\Program Files\MiKTeX 2.5\miktex\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\Perl\bin\;C:\Program Files\Hummingbird\Connectivity\8.00\Accessories\;C:\Program Files\Hummingbird\Connectivity\8.00\NFSClient;C:\Program Files\Subversion\bin;C:\MinGW\bin;C:\PalmOSCygwin\bin;C:\WINDOWS\system32\WindowsPowerShell\v1.0

When I run wubi.exe I get the Windows security warning, when I ask to Run, there is a pause, a beep and nothing else happens.

share|improve this question
    
Hey, Is there no output at all? Are you connected to the internet on the windows XP machine? And as far as I can see I don't see a link to your Python 3.* installation in your path. –  mojo706 Feb 13 '13 at 10:43
    
I have worked out that in %TEMP% a folder is created: Temp\py%%%.tmp This has a pyrun.exe and a pylauncher.exe, neither will run (The instruction at 0x77c460cb referenced memory at 0x00000000. The memory could not be read.) There are two .pyo files and the python23.dll in the folder and some sub-folders. In one of the sub-folders there is the cyqwin.dll and so I have removed cyqwin from my PATH, but still no luck –  user130691 Feb 13 '13 at 13:52
    
Do you have any Python environment variables set? i.e. check this bugs.launchpad.net/wubi/+bug/365501/comments/20 –  bcbc Feb 13 '13 at 17:32
    
it is possible to install different version of python on the same machine. please try out version 2.7 and tell me the result. –  mojo706 Feb 14 '13 at 13:10
    
There were/are no (obvious) Python environment variables set (such as PYTHONCASEOK). I unistalled Python 3.3 and installed Python 2.7.3. Executing python.exe -E main.pyo returns "RuntimeError: Bad magic number in .pyc file" –  user130691 Feb 14 '13 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.