Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Recently my installation of Ubuntu 13.04 has decided to stop going to sleep. I shut the lid and in power settings it is told to sleep but the computer only locks. I have tried running "sudo pm-suspend" and nothing happens at all. I get the same effect when trying to hibernate. Any suggestions on where to start troubleshooting?

Cheers

share|improve this question
add comment

marked as duplicate by Jorge Castro, Nathan Osman, Rinzwind, hhlp, Javier Rivera Feb 13 '13 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 5 down vote accepted

Thanks Jorge Castro, after following that link I went to the Raring Ringtail Testing and Discussion page and searched for suspend. Turns out it was nothing to do with 13.04 at all (which I partly suspected).

User ft_ had an answer to his question on ubuntu forums:

I got it.

It was caused by a script which avoid suspend-bug with usb 3, located in [B]/etc/pm/sleep.d[/B] . I removed this well-known script and my comp went suspended without any trouble.

Sorry for the non-existing issue.

(Note that this script never caused issue before, ie with kernels 3.5 and 3.7.)

Same problem. Just disabled one of the scripts in /etc/pm/sleep.d and it works now.

Cheers!

share|improve this answer
    
In my case deleting the /etc/pm/sleep.d/novatel_3g_suspend script fixed the problem –  Peter Szanto Jul 16 '13 at 7:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.