Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Google Chrome. This is the first thing I did after installing Ubuntu. I went into firefox, and went to chrome.google.com, and hit the button. I don't like package managers, and avoid the command line like the pox.

Then, I started using Google Chrome. I went to Kongregate, and clicked on a game. It told me I didn't have flash. A few different websites told me the same. I assumed that they must have been wrong. I hit the link to Adobe, to install Flash, and it reassured me; of course, Google Chrome includes Flash. I checked my version - Chrome 5.0.375.126. Of course, I just downloaded it.

I scoured the internet for solutions. None worked. Many seemed to involve re-enabling Flash, or something like that. But insofar as I can tell, there is no Flash anywhere in my Chrome. I feel like I bought a Reese's cup, and found solid chocolate. I checked in the Chrome plugin manager, and everything. A few solutions told me to copy some garbage into my command line and hit enter (as almost all solutions to problems on linux entail). I did it, reluctantly, and it did nothing.

I thought Flash was supposed to come with Chrome. But it didn't. Sooooo... What gives?

Google Chrome version: Google Chrome 5.0.375.126 (Official Build 53802) WebKit 533.4 V8 2.1.10.15 User Agent Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.126 Safari/533.4 Command Line /opt/google/chrome/google-chrome

Operating System: Ubuntu 10.4 64 bit.

share|improve this question

7 Answers 7

up vote 21 down vote accepted

I don't think Google Chrome for 64 bit comes bundled with Flash. I personally install the "Adobe Flash" (use those as search terms) in the Software Center and restart Chrome and it works.

Or you can just click here:

flashplugin-installer Install flashplugin-installer

share|improve this answer
2  
Thank you for being magic. –  Daniel Aug 18 '10 at 6:02
1  
Some how flashplugin-installer was already installed on my system and flash still would not work. I unistalled then reinstalled it and now flash works fine in chrome. –  deft_code Aug 18 '10 at 18:06
3  
Consider installing ubuntu-restricted-extras, which will bring in a lot of restricted packages like Flash. Unless you have an ideological reason not to (which is fine), it will save you a lot of time. –  Matthew Oct 18 '10 at 21:27
  1. Download

    What I usually do is download the Flash player from Adobe's site (since I use a 64-bit system, I download the 64-bit plugin).

  2. Extract package

    Then, in a terminal, run gksudo nautilus.
    Extract the package by right-clicking on the downloaded package and selecting "Extract Here". Enter the folder and you will find a file named libflashplayer.so.

  3. Copy the file libflashplayer.so into either:

    • /usr/lib/firefox-addons/plugins (for Firefox)
    • /usr/lib/chromium-browser/plugins (for Chromium)

That is it!

share|improve this answer

sudo apt-get install ubuntu-restricted-extras - solve this problem

share|improve this answer
    
Did you miss "avoid the command line like the pox." ? –  Alaukik Sep 16 '11 at 16:28
    
You can also use the Software Center: apt://ubuntu-restricted-extras Except I can't get the apt:// link to work. Search for it in the software center. –  Someone Somewhere Apr 28 at 14:26

I noticed that chrome does get some plugins out of the firefox plugin directories. If a working Flash plugin is installed in firefox it is likely to work in Chrome. The flashplugin-installer package basically installs Flash for firefox.

share|improve this answer

The location of the plugin for Google Chrome is: /opt/google/chrome/libgcflashplayer.so

share|improve this answer

I've just found a solution for those who has flash working on firefox but not on chromium. It's based on the fact that every browser has it's own plugins directory:

  • /usr/lib/firefox-addons/plugins (for Firefox)
  • /usr/lib/chromium-browser/plugins (for Chromium)

So, the only thing you've to do is to unificate them, aka, making one the link to the other. Probably, all plugins are on Firefox plugins directory, but it isn't worth to ensure that:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

If Firefox is the one where all plugins are, do the next. If not, do the opposite:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Finally, restart Chromium so changes take effect.

Probably, it wouldn't be a bad idea to create a bug report on chromium/firefox package mantainers to alert about the bug and the simple solution.

See you!!

share|improve this answer

If you are using Chrome 19.

  1. Go to about:plugins
  2. Click Details button in top right.
  3. Flash plugin consists of two libs. Disable /opt/google/chrome/PepperFlash/libpepflashplayer.so

Flash is back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.