Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual-boot UEFI laptop, with Ubuntu and Windows. I installed rEFInd to boot to these systems, and it worked fine, but my linux system was triplicated. I supposed it was because of rEFInd searching for any vmlinuz and all these, so I added the line scan_all_linux_kernels 0 into refind.conf.

After this, the extra booting options disappeared, but when I select Ubuntu, I get the GRUB menu to select it again.

I want to disable GRUB, so that the system boots from rEFInd. I have tried to apt-get remove all grub and grub2 packages, but GRUB still appears.

share|improve this question
add comment

2 Answers 2

I seem to have solved it, although I don't understand why.

I have reinstalled grub, but telling it NOT to generate menu.lst

I have renamed /boot/grub/to /boot/grub_back/, which has broken the boot. From a live USB boot, I have renamed it back to original and, after this, GRUB doesn't start any more after rEFInd.

Problem solved, but in a strange way.

share|improve this answer
add comment

Your GRUB is still starting; it's just that it's not presenting a menu any more. A cleaner solution is to change scan_all_linux_kernels 0 back to scan_all_linux_kernels in refind.conf, uninstall GRUB via dpkg or apt-get, and then trim any duplicate entries in the rEFInd menu in a more targeted way. I can't be more precise about this last point without knowing precisely what the existing options are, though. Also, be aware that in some configurations, you should have multiple Linux options in rEFInd, since each one boots a different kernel. This is equivalent to having multiple Linux entries in GRUB, each of which boots a different kernel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.