Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to this news , there is an official fix for secure boot. Will Ubuntu adapt it?

If so, how long should it take? And does it allow booting new computers from Wubi?

share|improve this question
add comment

2 Answers

No.

Ubuntu already supports secure boot, as mentioned in the real source of the news:

Does this mean Linux distributions can now support Secure Boot? They've actually been able to for a while. Ubuntu shipped with Secure Boot support last October, and Fedora shipped with Secure Boot support in January. Both used Shim rather than the Linux Foundation loader, and Shim's also being used by a variety of smaller distributions. The LF loader is a different solution to the same problem.

Wubi doesn't work on UEFI systems because it uses grub4dos which doesn't support GPT (GUID partition table) disks. This is unrelated to secure boot, other than the fact that Secure boot requires UEFI. That's the first problem.

The secure boot would be the second problem to solve since whatever solution provided would have to be signed to be useful (I would guess since I claim no expertise on this).

The third problem would be that someone should be working on it and - unless it's top secret - no information I have seen indicates that anyone is addressing the problem. The bug report has seen no change from Wishlist and remains Unassigned: https://bugs.launchpad.net/wubi/+bug/694242

share|improve this answer
    
Just to clarify,I knew ubuntu supports secure boot but this is the official fix. :D –  Will Feb 13 '13 at 0:48
add comment

I knew ubuntu supports secure boot but this is the official fix.

Not really. The Linux Foundation has released its fix in the form of the PreBootloader program. Ubuntu 12.10 and Fedora 18 both use another fix in the form of the shim program. (Fedora 18 uses a newer and more capable version of shim.) Neither solution has any more claim to being "official" than the other, except in the sense that certain organizations might support one solution or the other. In that sense, shim is "more official" than PreBootloader for Ubuntu, since shim is included in Ubuntu. FWIW, Matthew Garrett, the author of shim, has written this blog post that compares and contrasts the two programs. He says he's working on integrating the PreBootloader approach into shim, effectively combining the two programs into one.

In addition to the issues with GPT that bcbc has identified, a more fundamental problem with WUBI is that it doesn't support EFI-mode booting. To work on an EFI-based installation of Windows, WUBI would need to support an EFI-mode boot loader. Patching grub4dos to support GPT would be insufficient to this task. The LF PreBootloader also does nothing to help, since it requires the use of an EFI boot loader to follow itself -- hence the name *Pre*Bootloader.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.