Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a smart card reader (SCR3310) to work under Ubuntu 12.10. I have used this same card reader with Linux Mint and Previous versions of Ubuntu. I have installed pcsc-tools,pcscd libccid, libnss3-tools, and coolkey. The driver for the card reader is included in libccid.

When I run pcsc_scan the terminal returns the error, SCardEstablishContext: Service not available. If I understand this correctly, the error is indicating that it can't contact the pcscddaemon/service. When I check service pcscd status it returns * pcscd is not running. If I try sudo service pcscd start, I get no error but the service doesn't start. I also tried the force-reload option, it returns * Restarting PCSC Lite resource manager pcscd [failed]

For what it's worth, the card reader and supporting software currently work under my Mint partition. So far I haven't seen where I'm missing anything under the Ubuntu install that is present under Mint. Also, I have tried un-installing/re-installing pcscd.

Is it likely that there is another service that pcscd depends on that may not be present?

Operating System: Ubuntu 12.10 32-bit
System: Dell Latitude E6500
Card Reader: SCR 3310

share|improve this question
    
FTR, i had to update the smartcard reader's firmware in my dell laptop to make the reader work under linux. i started out from this: natisbad.org/E4300 and i remember struggling to make a bootable USB to update it with the fw extracted from this: DELL_CONTROLPOINT-SECURITY-M_A18_R276445.exe that i found here ftp.ins.dell.com/Control%20Point – Attila Lendvai Oct 31 '15 at 23:09

Finally got back to tinkering with the card reader again today. The good news is I got it working. The bad news is, I'm not sure which step fixed it...

  1. Removed Coolkey
  2. Installed CacKey (available at SourceForge.mil). Tested but still couldn't restart pcscd
  3. Looked through the README.gz file and found a reference to libusb. I didn't have libusb in my /lib directory on Ubuntu but I did on Mint. So I sym-linked to the /lib/libusb on my Mint partition. (Yes, I realize that would not be an option for everyone, but it's what I did.) Still couldn't get pcscd to restart.
  4. Removed and Re-installed pcscd. I was then able to contact the reader with pcsc_scan. Keep in mind I had already un-installed/re-installed pcscd before.
  5. Added Security device in Firefox and pointed to /usr/lib/libcackey.so. Worked as expected

I'm going to continue to tinker and see if I can Isolate the step that worked. (Have a second laptop running 12.10 with the same problem.)

share|improve this answer
    
This is not my answer, I copied it from the answer part @Argusvision put in the question. – phunehehe Jul 1 '14 at 10:06
    
I believe step 4. was the solution as that would have restarted the pcscd service. Probably all that was needed was sudo service pcscd restart. – Jim Parker Jan 17 '15 at 17:44
    
if you have both pcscd and scdaemon installed, then they may be stepping on each other's toes when trying to acquire exclusive access to the reader. either uninstall scdaemon or configure it to use pcscd (my card+reader doesn't work with scdaemon but does work with pcscd): wiki.archlinux.org/index.php/GnuPG#GnuPG_together_with_OpenSC you may need to find the exact path on your system using '$ locate libpcsclite.so' – Attila Lendvai Oct 31 '15 at 23:07

In my case:

First I install the original drivers (OMNIKEY-3021), but it doesn't work immediately. sudo service pcscd status show:

~$ sudo service pcscd status

pcscd is not running

Then I just purge and then reinstall again pcscd and now it works.

If it still doesn't work, just try:

sudo service pcscd start
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.