Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I want to sync my notes with WebDAV server, I get the following error messages in Gnote and Tomboy:

This synchronization addin is not supported on your computer. Please make sure you have FUSE and wdfs correctly installed and configured

How can I set up FUSE and wdfs?

Gnote WebDAV connecting error Tomboy WebDAV connecting error

There is also a reported bug on Launchpad: Tomboy Notes cant Sync with WebDav, but I don't know if it is a bug.

share|improve this question
1  
The answer by Khurshid Alam did not work for Ubuntu 14.04. The step, "./configure" fails with error message: >checking for WDFS... configure: error: Package requirements (fuse >= 2.5.0 neon >= 0.24.7 glib-2.0) were not met: No package 'glib-2.0' found I was able to get the code to compile by adding the glib-2.0 package. This command should be run before the "./configure" command. > sudo apt-get install libglib2.0-dev Create a webdav mount point for tomboy data on your local machine. Enter the following command from the terminal. I am using an owncloud for webdav services, so your directory str –  Chad E Chenault Jun 6 at 8:19

2 Answers 2

Since fuse is a part of kernel I think its missing wdfs(webdav filesystem) which is NOT in the repository.

Install underlying libraries:

sudo apt-get install checkinstall libfuse-dev libneon27 libneon27-dev
sudo apt-get install python-fuse fuse-utils

Get & install wdfs:

wget http://noedler.de/projekte/wdfs/wdfs-1.4.2.tar.gz
tar xzvf wdfs-1.4.2.tar.gz
cd wdfs-1.4.2
./configure
sudo checkinstall
sudo dpkg -i wdfs_1.4.2-1_*.deb

If this doesn't work, then its probably this Bug:575061

Other Workaround:

  • Use SSH note sync instead.
  • Use wdfs to mount your webdav share somewhere, and use Local Directory note sync and have it point at your webdav share. This is exactly what the Tomboy add-in does, anyway.
share|improve this answer

I use Ubuntu 14.04 and was able to get Tomboy notes to sync with webdav on an owncloud server installation. I was not able get tomboy to do a direct sync with webdav and wdfs. My work around was to use menu:syncronization/service = "Local Folder".

  1. You need owncloud server access.
    1. Install owncloud client on the computer you want tomboy access. It is available in software center as "ownCloud desktop sync client" with version "owncloud-client 1.5.0+dfsg-4ubuntu1". This will create a folder at /home/user/owncloud. Everything in the owncloud folder will be synced with the owncloud server.
    2. Close Tomboy application.
    3. Copy /home/user/.local/share/tomboy folder to /home/user/owncloud. You can keep the .local copy in case you delete your owncloud version.
    4. Start Tomboy
    5. Goto menu:syncronization/
    6. choose service = "Local Folder"
    7. choose folder path = /home/user/owncloud/tomboy
    8. choose "save" button to store your settings

This is working for me.

share|improve this answer
    
Hey! Nice answer, but could you fix up the formatting so it follows our formatting guidelines? That would be great! Thanks :) –  Seth Jun 16 at 14:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.