Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I deleted two unused user accounts. Now I am unable to login even into my own account. I rebooted in recovery mode in the root shell and tried to restore the back-up of /etc/passwd. However, the filesystem is read-only!!

I can only access root shell via recovery.

Can you help me?

share|improve this question
@Jobin There is an existing bug for this. You may want to add your vote (the green writing near the top-left of the bug page). – Paddy Landau Feb 12 '13 at 16:59
Thanks @PaddyLandau. Thought it was a security measure rather than a bug. Marked it as it affects me too :) – i08in Feb 12 '13 at 17:06
Well, it used to work until (I think) 11.10. – Paddy Landau Feb 12 '13 at 21:19
up vote 32 down vote accepted

If I am not wrong, the filesystem is mounted read-only by default in Recovery mode. To mount it as read-write, go the recovery mode and choose root. Now type the following command:

mount -o rw,remount /

Note the spaces, you'll get an error if you ignore the spaces, or add extra ones too. And then you can copy as you tried earlier.

share|improve this answer
thanks mate, it worked! – Louis Feb 12 '13 at 15:31
If your home is on an extra partition, you may also need the command mount --all. – Paddy Landau Feb 12 '13 at 21:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.