Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a fresh Ubuntu 12.10 system I am trying to install the Mozart ( programming environment. Unfortunately I got the following error message reporting missing dependencies.

>> sudo apt-get -f install mozart mozart-doc mozart-stdlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
mozart-doc is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mozart:i386 : Depends: emacs23:i386 or
 mozart-stdlib : Depends: mozart (>= 1.4.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I fix this issue ?

My sources.list file's content (not modified since fresh installation)

deb quantal main restricted
deb-src quantal main restricted

deb quantal-updates main restricted
deb-src quantal-updates main restricted

deb quantal universe
deb-src quantal universe
deb quantal-updates universe
deb-src quantal-updates universe

deb quantal multiverse
deb-src quantal multiverse
deb quantal-updates multiverse
deb-src quantal-updates multiverse

deb quantal-backports main restricted universe multiverse
deb-src quantal-backports main restricted universe multiverse

deb quantal-security main restricted
deb-src quantal-security main restricted
deb quantal-security universe
deb-src quantal-security universe
deb quantal-security multiverse
deb-src quantal-security multiverse

deb quantal partner
deb-src quantal partner

deb quantal main
deb-src quantal main
share|improve this question

First try to install emacs23 by using sudo apt-get install emacs23:i386 then re-run that command.

Please make sure you don't have any PPAs that might contain versions of packages that doesn't fit the dependencies.

share|improve this answer
I already tried that but it failed with: 'The following packages have unmet dependencies: emacs23:i386 : Depends: emacs23-bin-common:i386 (= 23.4+1-4ubuntu1) but it is not going to be installed Depends: libm17n-0:i386 (>= 1.6.1) but it is not going to be installed Depends: libotf0:i386 (>= 0.9.11) but it is not going to be installed E: Unable to correct problems, you have held broken packages.' – Manuel Selva Feb 12 '13 at 17:03
@ManuelSelva look at the new paragraph. – smartboyhw Feb 12 '13 at 17:17
first, thanks for your help. I unchecked all "Other Sources" in Software Sources app (I guess this app modifies apt sources.list files) and tried again to install either emacs23:i386 or mozart but I still get the smae problem. – Manuel Selva Feb 12 '13 at 17:36
@ManuelSelva post your /etc/apt/sources.list into your question please. – smartboyhw Feb 12 '13 at 17:41
Done (question edited) – Manuel Selva Feb 12 '13 at 18:28

Try sudo aptitude install mozart mozart-doc mozart-stdlib.

Aptitude will attempt to find solutions which may involve modifying other packages. It may give you more explanation of the problem and options for fixing it.

share|improve this answer
Unfotunately it doesn't solve the issue and the only thing aptitude proposes is to keep actual package configuration (meaning not installing anything) – Manuel Selva Feb 12 '13 at 13:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.