Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I decided to update my JDK7 to recent version from here.

Corresponding x64 tag.gz archive for my architecture has been downloaded and extracted to /usr/lib/jvm as usual. All previous versions of Java were installed before the same way. But before setting new alternatives for java, javac and javaws I removed all existing alternatives using the following commands:

sudo update-alternatives --remove-all java
sudo update-alternatives --remove-all javac
sudo update-alternatives --remove-all javaws

Now when trying to install new alternatives I get the following:

sudo update-alternatives --install /usr/lib/jvm/jdk1.7.0_13/bin/java java /usr/bin/java 1
update-alternatives: error: alternative path /usr/bin/java doesn't exist.

Of course, /usr/bin/java doesn't exist but /usr/bin does? What's wrong with it and how can I fix it?

share|improve this question
1  
There is a webupd8 java ppa for updating the Oracle JDK7. –  BuZZ-dEE Feb 12 '13 at 13:13

2 Answers 2

up vote 3 down vote accepted

It's my epic fault! :)

I mixed up the arguments of update-alternatives. The right command line must be:

sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk/bin/java 1
share|improve this answer
    
I posted it as answer 'cause it solved the question. I don't know for sure whether I should delete the question (as it solved by myself in short time) or post the answer. –  Ezze Feb 12 '13 at 12:52
    
Posting the answer is generally the right thing. Though, this problem is so localized, I'm not sure anyone will find it useful in the future. Who knows, I could be wrong. :) –  Nathan J. Brauer Feb 12 '13 at 13:25
    
At any rate, next time you install/upgrade Java, I highly recommend using the webup8 java ppa (different link) -- It makes everything SO much easier (just make sure you purge your current installation first). –  Nathan J. Brauer Feb 12 '13 at 13:27

Since you are updating from a previous Java version, which you have removed manually, you would have to execute the following command twice. You get an error message the first time and it works when you execute it the second time.

sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk/bin/java" 1

Source: Easy Linux Project

share|improve this answer
    
Thanks for the anwser but the issue is that I mixed up update-alternatives's arguments. The right command works with the first attempt. –  Ezze Feb 12 '13 at 12:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.