Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to figure out how to get my wireless driver to work since I installed Linux a month ago because Windows was crapping out on me. I'm new to Linux, so I'm unfamiliar with how to get certain things to work. Any suggestions?

01:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [8086:008a] (rev 34)
    Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5325]
    Kernel driver in use: iwlwifi
--
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
    Subsystem: Dell Device [1028:04d8]
    Kernel driver in use: r8169



*-network DISABLED      
       description: Wireless interface
       product: Centrino Wireless-N 1030
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 34
       serial: 4c:eb:42:77:d6:f2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-23-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:51 memory:d0600000-d0601fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 05
       serial: 84:8f:69:d2:db:a4
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip=192.168.1.73 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:49 ioport:2000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
share|improve this question
    
Welcome to AskUbuntu! You might want to give this question oon troubleshooting wireless issues a look. It might also be useful to post the output of the commands posted on the answer there into your question here so people know exactly what hardware you have. –  Oyibo Feb 12 '13 at 7:46

1 Answer 1

This had worked for me, but haven't figured out yet how to make it permanent.

Open terminal with Ctrl+Alt+T and type the following commands:

sudo rmmod -f iwlwifi 

It may ask you to input your password after you press enter

sudo modprobe iwlwifi 11n_disable=1

The above will disable the N mode on your wireless card and it should start working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.