Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an update a few days ago, I am not able to connect to any wireless AP. I tried basic stuff like restarting and disabling wireless by the hardware switch. Clicking on any AP will show that graphic that it shows, and I get a Wireless Disconnected message.

This is the output of ifconfig

eth0      Link encap:Ethernet  HWaddr dc:0e:a1:6e:bb:b2  
          inet addr:10.10.11.86  Bcast:10.10.11.255  Mask:255.255.255.0
          inet6 addr: fe80::de0e:a1ff:fe6e:bbb2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24076 errors:0 dropped:39 overruns:0 frame:0
          TX packets:15334 errors:0 dropped:0 overruns:0 carrier:5
          collisions:0 txqueuelen:1000 
          RX bytes:15108360 (15.1 MB)  TX bytes:2980605 (2.9 MB)
          Interrupt:46 

eth1      Link encap:Ethernet  HWaddr e4:d5:3d:7b:a6:cb  
          inet6 addr: fe80::e6d5:3dff:fe7b:a6cb/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:15 errors:2 dropped:0 overruns:0 frame:25528
          TX packets:171 errors:86 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2045 (2.0 KB)  TX bytes:41601 (41.6 KB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1329 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1329 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:101408 (101.4 KB)  TX bytes:101408 (101.4 KB)

The output of lshw -C network is

*-network               
       description: Ethernet interface
       product: AR8152 v2.0 Fast Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: c1
       serial: dc:0e:a1:6e:bb:b2
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=10.10.11.86 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:46 memory:e0500000-e053ffff ioport:2000(size=128)
  *-network
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth1
       version: 01
       serial: e4:d5:3d:7b:a6:cb
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:e0400000-e0403fff

I also looked similar problems and a few suggested adding these lines to /etc/modprobe.d/blacklist.conf

blacklist mac80211
blacklist brcm80211
blacklist cfg80211
blacklist wl
blacklist lib80211_crypt_tkip
blacklist lib80211

and this below line to /etc/rc.local

modprobe wl

I restarted after these changes, and still cannot connect.

A few other posts also suggested I install packages such as firmware-b43-installer, bcmwl-kernel-source and linux-firmware. However, these are already installed.

I also deleted the /etc/udev/rules.d/70-persistent-net.rules so it could be created from fresh at start and the contents are as follows:

# PCI device 0x14e4:/sys/devices/pci0000:00/0000:00:1c.1/0000:08:00.0 (wl)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="e4:d5:3d:7b:a6:cb", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

I am really at a loss to understand what is happening and how to arrive at a solution. Can anyone help?

share|improve this question
    
Please reboot, then try to connect via Wi-Fi, then connect via wire and then use apport-bug to file a bug report in Launchpad against the network-manager package. –  jdthood Feb 14 '13 at 9:44
add comment

closed as too localized by Bruno Pereira Feb 21 '13 at 10:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

You want to first remove everything from your /etc/modprobe.d/blacklist.conf that you may have added, as well as that one line you added to /etc/rc.local.

First thing to try:

With your wifi device plugged in, search for "Software Sources" and open the app. Go to the "Additional Drivers" tab. There you will find an option to enable your wireless device.

Second thing to try:

If this does not work, uninstall and then reinstall the bcmwl-kernel-source package, then reboot. You should then perform the step above to make the change survive each kernel upgrade.

You can see a further explanation here. Basically, when you upgraded the kernel, the wireless driver, which is an extra that needs to be built into each kernel, was not carried along.

share|improve this answer
add comment

You should try following command:

rfkill unblock all
share|improve this answer
add comment
up vote 0 down vote accepted

Sorry guys, I am not able to try out anything you suggested. One of the answers that came to my mind, was a fresh install. Thats what I did. The problem does not exist now.

EDIT:

It happened again on a fresh install. This time, I went to the software sources, and chose the proprietary drivers tab. I chose to disable the wireless device and applied the new settings. Point to note, that before applying, the broadcom device was selected and underneath the wifi entry, it was written that this is using an alternate driver (where it currently mentions, device is not working).

I restarted after applying the changes and now its working.

Please look at pic for better understanding.

Disabled broadcom device

share|improve this answer
add comment

This is a bit of a guess but I had to set the channel rather than use auto. You can download apps to point you at a good channel if this is the problem

share|improve this answer
    
Which apps, are they in the software centre? –  Warren Hill Feb 12 '13 at 15:57
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.