Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.10(64 bit). But was not able connect to internet using my MTS modem. It detects My modem, but says 'not enabled' even after enabling mobile broadband. But some times, very rarely (once in a day) the 'not enabled' changed to somthing like 'CDMA home network...evdo' and then i was able to connect.

I googled around and found that this is due to buggy 'modem manager 0.6.0.0' which comes shipped with ubuntu 12.10. So I removed it using software center and installed modem manager version 0.5.2.0) from a .deb package i have downloaded, using this code in terminal.

sudo dpkg -i modemmanager_0.5.2.0-0ubuntu2_amd64.deb

The problem has gone even worse. The bad part remained bad while the good part worsened. Now i can't connect to internet even when the 'CDMA home network...evdo' appears in place of 'not enabled'.

People found the solution working, every where around different forums. What could have gone wrong with mine??

I have posted the same on ubuntuforums.org but no reply yet.

Update

Now ubuntu is giving an error message in notification area. So far what i have understood is, it is due to the modemmanager_0.5.2.0 i have installed. It requires some sort of umnet dependencies. Since i have installed it offline through .deb package i think it lacked some dependencies. But since i can no more connect to internet i cannot repair the dependencies. Kindly reply if you have any idea about umnet dependencies or something related to it.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

No reply yet, any ways, I have found a solution.

If you have a Windows PC or you have dual booted your PC with one of the Windows OS. Connect your MTS modem while in Windows and change the network type from broadband to hybrid. Then boot to Ubuntu, It should connect easily. As far as i concluded that the modem manager version 0.6.0.0 have a bug and do not detect 3G network. However it somehow manages to detect it when network type is changed to hybrid.

I thought it would help other users with same problem. It should also work with other wireless broadband like TATA photon plus.

share|improve this answer
    
I have the same problem but cannot figure out how to change network from broadband to hybrid. Please tell how can I do that? –  Aman Deep Gautam Jul 26 '13 at 6:28

First you should connect any of WiFi available in your range with Internet Access.

Then connect to your MTS MBlaze Connection.

When you get connected to your modem disconnect WiFi. Now you are online with your modem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.