Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to a server via SSH. I am getting the following log from using the command: ssh -vvvT ubuntu@ec2-176-34-121-133.eu-west-1.compute.amazonaws.com.

Please could someone help me debug this log as I am getting no where with it.

 5742:~/.ssh$ ssh -vvvT ubuntu@ec2-176-34-121-133.eu-west-1.compute.amazonaws.com 
OpenSSH_6.0p1 Debian-3ubuntu1, OpenSSL 1.0.1c 10 May 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to ec2-176-34-121-133.eu-west-1.compute.amazonaws.com [176.34.121.133] port 22.
debug1: Connection established.
debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/karl/.ssh/id_rsa" as a RSA1 public key
debug1: identity file /home/karl/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/karl/.ssh/id_rsa-cert type -1
debug1: identity file /home/karl/.ssh/id_dsa type -1
debug1: identity file /home/karl/.ssh/id_dsa-cert type -1
debug1: identity file /home/karl/.ssh/id_ecdsa type -1
debug1: identity file /home/karl/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-3ubuntu1
debug1: match: OpenSSH_6.0p1 Debian-3ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-3ubuntu1
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "ec2-176-34-121-133.eu-west-1.compute.amazonaws.com" from file "/home/karl/.ssh/known_hosts"
debug3: load_hostkeys: found key type ECDSA in file /home/karl/.ssh/known_hosts:3
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 59:c4:29:87:87:50:f7:eb:fb:ea:2a:39:8b:07:1a:33
debug3: load_hostkeys: loading entries for host "ec2-176-34-121-133.eu-west-1.compute.amazonaws.com" from file "/home/karl/.ssh/known_hosts"
debug3: load_hostkeys: found key type ECDSA in file /home/karl/.ssh/known_hosts:3
debug3: load_hostkeys: loaded 1 keys
debug3: load_hostkeys: loading entries for host "176.34.121.133" from file "/home/karl/.ssh/known_hosts"
debug3: load_hostkeys: found key type ECDSA in file /home/karl/.ssh/known_hosts:4
debug3: load_hostkeys: loaded 1 keys
debug1: Host 'ec2-176-34-121-133.eu-west-1.compute.amazonaws.com' is known and matches the ECDSA host key.
debug1: Found key in /home/karl/.ssh/known_hosts:3
debug1: ssh_ecdsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/karl/.ssh/id_rsa (0xb7f68a18)
debug2: key: /home/karl/.ssh/id_dsa ((nil))
debug2: key: /home/karl/.ssh/id_ecdsa ((nil))
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/karl/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp a2:34:c1:e2:9c:18:e3:46:8b:96:46:f3:59:4b:5f:cc
debug3: sign_and_send_pubkey: RSA a2:34:c1:e2:9c:18:e3:46:8b:96:46:f3:59:4b:5f:cc
debug1: Authentications that can continue: publickey
debug1: Trying private key: /home/karl/.ssh/id_dsa
debug3: no such identity: /home/karl/.ssh/id_dsa
debug1: Trying private key: /home/karl/.ssh/id_ecdsa
debug3: no such identity: /home/karl/.ssh/id_ecdsa
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).
5742:~/.ssh$ 
share|improve this question
    
your public key is not in the server... –  maniat1k Feb 11 '13 at 21:58
    
maniat1k - please can you confirm the line from the log which leads you to this conclusion –  bosra Feb 11 '13 at 22:02
    
read the end of the debug... debug1: Authentications that can continue: publickey debug1: Trying private key: /home/karl/.ssh/id_dsa debug3: no such identity: /home/karl/.ssh/id_dsa debug1: Trying private key: /home/karl/.ssh/id_ecdsa debug3: no such identity: /home/karl/.ssh/id_ecdsa debug2: we did not send a packet, disable method debug1: No more authentication methods to try. Permission denied (publickey). –  maniat1k Feb 11 '13 at 22:03
    
So why am I getting three different answers here? You are saying my public key is not on server. Another answer below says its permissions. Then another answer refers to authorised keys file –  bosra Feb 11 '13 at 22:26
    
your private key checks agaisnt your public key on the server inside a file called autorised_keys check that. like @Terry Wang said in his answer first make sure you copy the public ... –  maniat1k Feb 12 '13 at 1:20

1 Answer 1

First make sure you copy the public key to the SSH Host.

Show us the contents of ~ubuntu/.ssh/authorized_keys.

If public key is in place, make sure on the ssh host

  1. permission of the ~/.ssh folder is 700 (could be even tighter)
  2. ~/.ssh/authorized_keys is 600

And try again.

If still NO luck, stop the sshd on host service ssh stop and start it in the foreground in debug mode

/usr/sbin/sshd -Dd

Try to ssh to the host with -v and see what the output is. Most likely this is a folder/file permission issue.

share|improve this answer
    
hey I don't have an authorised_keys folder set up. Is this the problem? –  bosra Feb 11 '13 at 22:03
    
This is a file, you definitely need it in place to make public key authentication work. You can use ssh-copy-id -i identity_file ubuntu@ec2-176-34-121-133.eu-west-1.compute.amazonaws.com to get it done easily. –  Terry Wang Feb 11 '13 at 22:07
    
Terry, where should that file go? When I try to run the command,I get an error msg - No identities found –  bosra Feb 11 '13 at 22:14
    
The identity file is the public key, AWS will provide you a private key in PEM format, to get the public key out of it, you need to run openssl rsa -in you_private_pem -pubout -out public.key and then copy the public key to the host properly. –  Terry Wang Feb 11 '13 at 22:25
    
Terry, please could you provide a link describing this procedure please –  bosra Feb 11 '13 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.