Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems I somehow kicked out my 'diskdrive boot-option' for my blueray-diskdrive.

I tried to fix it with 'efibootmgr' but I'm not getting anywhere. I think I just don't understand how to use this program.

here is what efibootmgr tells me about my boot sequence:

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* ubuntu
Boot0001* ubuntu

Does anybody know how I can add my diskdrive to the sequence?

efibootmgr is giving me the following options:

efibootmgr version 0.5.4
usage: efibootmgr [options]
-a | --active         sets bootnum active
-A | --inactive       sets bootnum inactive
-b | --bootnum XXXX   modify BootXXXX (hex)
-B | --delete-bootnum delete bootnum (hex)
-c | --create         create new variable bootnum and add to bootorder
-d | --disk disk       (defaults to /dev/sda) containing loader
-e | --edd [1|3|-1]   force EDD 1.0 or 3.0 creation variables, or guess
-E | --device num      EDD 1.0 device number (defaults to 0x80)
-g | --gpt            force disk with invalid PMBR to be treated as GPT
-H | --acpi_hid XXXX  set the ACPI HID (used with -i)
-i | --iface name     create a netboot entry for the named interface
-l | --loader name     (defaults to \elilo.efi)
-L | --label label     Boot manager display label (defaults to "Linux")
-n | --bootnext XXXX   set BootNext to XXXX (hex)
-N | --delete-bootnext delete BootNext
-o | --bootorder XXXX,YYYY,ZZZZ,...     explicitly set BootOrder (hex)
-O | --delete-bootorder delete BootOrder
-p | --part part        (defaults to 1) containing loader
-q | --quiet            be quiet
   | --test filename    don't write to NVRAM, write to filename.
-t | --timeout seconds  set boot manager timeout waiting for user input.
-T | --delete-timeout   delete Timeout.
-u | --unicode | --UCS-2  pass extra args as UCS-2 (default is ASCII)
-U | --acpi_uid XXXX    set the ACPI UID (used with -i)
-v | --verbose          print additional information
-V | --version          return version and exit
-w | --write-signature  write unique sig to MBR if needed
-@ | --append-binary-args file  append extra args from file (use "-" for stdin)

So with '--create' I can create a new boot number. But this will only create another bootnumber for my Linux partition.

here is what hwinfo tells me about my diskdrive:

Hardware Class: disk
Model: "Hitachi HTS72757"
Vendor: "Hitachi"
Device: "HTS72757"
Revision: "JF4O"
Driver: "ahci", "sd"
Driver Modules: "ahci"
Device File: /dev/sda
Device Files: /dev/sda, /dev/disk/by-id/ata-Hitachi_HTS727575A9E364_J3340084HUZWHB, /dev/disk/by-id/scsi-SATA_Hitachi_HTS7275_J3340084HUZWHB, /dev/disk/by-id/wwn-0x5000cca68cd9e8ba, /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0
Device Number: block 8:0-8:15
BIOS id: 0x80
Drive status: no medium
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #29 (SATA controller)

This is a real problem for me, for I can't boot with a Live CD now.

Update:
So after a few hours of research google came up with the following results:

I tried

sudo efibootmgr --create --disk /dev/sda --part 1 --label "Precise - GRUB2" --loader \\EFI\\ubuntu\\grubx64.efi

of course I changed the given variables according to my system.

as "mount" told me I went on

sudo efibootmgr --create --disk /dev/sr0 --part 1 --label "Blueray" --loader \\EFI\\ubuntu\\grubx64.efi

assuming

\\EFI\\ubuntu\\grubx64.efi"

links to

/boot/efi/EFI/ubuntu

but I only got back the error

Could not open disk /dev/sr0: Read-only file system

Well I guess the attempt to create a bootoption for my disk drive via efibootmgr is the wrong way. The --create command obviously is trying to write something to the diskdrive.

So I tried to tell grub that there is a disk drive:

sudo grub-install --bootloader-id CD-ROM /dev/sr0

then

sudo reboot

I had a bootable Disk in my BRD-drive (tried two differend DVDs, both bootable on another system of mine). Before booting up the system from my Ubuntu partition the system seemed to check the DVD (I could hear the drive spinning at startup)

But the Ubuntu started as usual from the harddisk.

I just checked and saw that my command created this folder:

/boot/efi/EFI/CD-ROM

with another "grubx64.efi" like the one in

/boot/efi/EFI/ubuntu

I opened up the file with the nano editor but the file seems to be encrypted in a way nano doesn't understand (only jibberish)

here a small excert so you know what I mean:

MZ�^@^C^@^@^@^D^@^@^@��^@^@�^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^$

Has anybody an idea how I can restore the bootsequence to a standard value? Or how I can ad the blueray disk drive?

share|improve this question

3 Answers 3

I don't think efibootmgr is really suited to this task. In most cases, you can do what you want via the firmware's own user interface. Sometimes just selecting the built-in boot manager (typically by pressing a function key during the boot process, but which one varies from model to model) will cause it to re-detect your optical drive. In other cases, you may need to enter the setup utility (by pressing another function key or the Del key) and locate an option to set the boot order. Unfortunately, the user interfaces for all of this are highly variable, so I can't be more specific. Consulting your computer's or motherboard's manual might provide you with clues, but unfortunately, these manuals are getting vaguer and vaguer as time goes on.

share|improve this answer

Try unplugging/replugging your drive. Also Upgrading/Downgrading BIOS may help. I got mine fixed by plugging drive into another SATA port.

share|improve this answer

When you first power up your computer, try pressing "F2" to enter setup. if you set your disk drive higher in the boot order, it will boot off of a disk before it looks for an efi file on your hard drive. "F12" or "F10" may bring up a menu which may include an option to either boot from a disk or enter setup to configure options such as preferred boot order. which exact button varies by manufacturer, but "F2" is commonly used, "Del" or "delete" are also common options for entering setup.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.