Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sudo apt-get install xampp after above step the following error is shown

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xampp:i386 : Depends: python-gtk2:i386 but it is not going to be installed
              Depends: python-glade2:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
Question: xamp is NOT part of Ubuntu so why does your apt-get work? This is how to install Xamp: apachefriends.org/en/xampp-linux.html but I would strongly suggest to use the native LAMP stack. It is far more secure and a lot less hassle to get working. –  Rinzwind Feb 11 '13 at 18:19

2 Answers 2

I had the same error message.

Try this link:

http://daksh21ubuntu.blogspot.com/2012/01/how-to-install-xampp-in-ubuntu.html

I downloaded version 1.8.1 from this link:

http://www.apachefriends.org/download.php?xampp-linux-1.8.1.tar.gz

Worked perfect for me.

Good luck.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Aditya Feb 18 '13 at 8:56

maybe ubuntu repo does not come with xampp, you can download xampp from source and install xampp

# wget http://downloads.sourceforge.net/project/xampp/XAMPP%20Linux/1.8.3/xampp-linux-1.8.3-4-installer.run
# chmod 755 xampp-linux*
./xampp-linux*
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.