Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have network hangs through ssh.

Htpc is an asus m45m1-m pro, with pci wlan card lspci:

> 05:00.0 Ethernet controller: Atheros Communications Inc. AR2417
> Wireless Network Adapter [AR5007G 802.11bg] (rev 01)

I installed the server 12.10 x64 with the latest stable 3.6.3-030603-generic kernel.

When I connect to the htpc via putty I experience random network hangs. If I wait 1-100 seconds, the hang disappears after a while.

If I connect to the backend desktop lxde, via vnc, it also happens. If I click on somewhere else nothing happens. If I wait OR if I restart the local vnc application and reconnect, the hang is gone, and the click what I have done before already happened.

If I restart putty, hang also disappears.

If I have network activity (i.e. youtube or downloading something) the hang happens often.

I already tried to ping everything from every side, so I think it's not a timeout problem.

Let me know what additional logs you might need to assist me.

share|improve this question
    
Thanks for the edit! I'm a newbie! :) –  rigo Feb 11 '13 at 10:25
    
Could it be the TCPKeepAlive or ServerAliveInterval setting? manpagez.com/man/5/ssh_config –  OrangeTux Feb 11 '13 at 10:42
    
i add ~/.ssh/config file and tried ServerAliveInterval 0, 1, 10, 100, 1000 with service ssh restart each time no luck. i think ill try it out with another wlan card. i had no problems with the at3iont-i deluxe board almost the same setup only with 12.04 x86. –  rigo Feb 11 '13 at 10:54
    
no luck with the suggestions, i purcased a new pcie 1x wlan card and check if the failure is gone or not. –  rigo Feb 14 '13 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.