Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran the following commands

sudo apt-get install libapache2-mod-wsgi
sudo a2enmod mod-wsgi

I keep getting this extremely frustrating message

ERROR: Module mod-wsgi does not exist!

Please help.

share|improve this question
1  
sudo a2enmod will give you list of modules installed. Just enable wsgi as said by ajmitch –  sagarchalise Feb 9 '11 at 5:20
add comment

3 Answers

up vote 9 down vote accepted

Using sudo a2enmod wsgi should enable the module for you once you reload apache, as most modules don't need the mod_ prefix when enabling them.

share|improve this answer
    
i tried sudo a2enmod wsgi but even I m still getting the same error. I typed sudo a2enmod and these are the choices I got dpaste.de/NEIcf It does not contain wsgi. Is it ok to ask this question here or do I need to post a new question? –  Sam007 Aug 21 '12 at 17:22
add comment
sudo nano /etc/apache2/mods-available/wsgi.load

add the next string to the file

LoadModule wsgi_module /usr/lib/apache2/modules/mod_wsgi.so

save, then

sudo a2enmod wsgi
sudo service apache2 restart
share|improve this answer
add comment

Try adding the wsgi.load and wsgi.conf from mods-available to mods-enabled manually and then restart Apache.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.