Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is posed because I finished building a new rig with a GA-990FXA-UD3 mobo, unlocked FX 4100 proc, 16gb RAM, and GT 640 graphix card. Started it up and tested the mobo (via BIOS) and all was beautiful with it and all its many ports. Then I grabbed a copy of Ubuntu 12.04 64bit and fired up the Live disc. Besides not recognizing my two monitors off the rip, things seemed okay except I was getting a Wired Connection disconnected pop up in the top right hand corner. Then I noticed that several peripherals (USB) were not lit up. Tested all the USB ports; only two were live. Tested my LAN CAT5 cable to my router with another computer; it was live.

Shut down the rig and fired it up a couple more times with the same results. Then I grabbed another disc, Xubuntu 64bit; same thing. Grabbed an Ultimate Edition 3.5 64bit; same thing. Hours later I thought that it was related to the Realtek r8169 module. Then by some chance I grabbed an older Ubuntu version; 10.04 LTS. However, I did not realize that it was 32bit. Everything worked; USB, LAN, etc. So I installed 10.04 Ubuntu (again did not realize that it was 32bit) and everything worked great. Decided on a whim to upgrade through Ubuntu to 12.04. Everything worked great. Puzzled, I continued to update and add my normal apps. Tried to install Chrome and the package installer gave me a wrong architecture error. It was only then that I realized I had 32bit installed.

Immediately, I grabbed the 12.04 64bit Live DVD and rebooted. Same problems. There is no doubt that the hardware that I have supports 64bit so that is not the issue. Why the 64bit kernel and the 32bit kernel act so differently in (seemingly) compatible hardware is beyond me.

Does anybody have some explanation about this strange phenom? I am okay with 32bit but I would really prefer to have 64bit if it is possible.

share|improve this question
2  
Update: It was an esoteric setting in the BIOS. I had to enable the IOMMU setting. See this post ubuntuforums.org/showthread.php?t=2114055. I am currently running 64-bit 12.04 smoothly with no problems. –  drDoctor Apr 8 '13 at 2:23
    
You're my lord and savior: it's the IOMMU setting as well that prevented me from connecting on both 12.04 and 13.10. Prevented both my Ethernet connection and Wifi PCI card to work... (Same Motherboard as you have). –  hadware Nov 5 '13 at 17:23
add comment

1 Answer 1

Step #1: In terminal type:

sudo gedit /etc/default/grub

Step #2: Edit this line to read:

GRUB_CMDLINE_LINUX="iommu=soft" 

Step #3: Save and close Gedit

Step #4: In terminal type:

sudo update-grub

Step $5: In bios disable iommu

Sources: http://ubuntuforums.org/showthread.php?t=2114055&page=2

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.