Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello

My trouble is:

Could not open file /var/lib/dpkg/status - open (2: No such file or directory)

I tried:

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

but there is nothing in the directory dpkg.

How do I regenerate the directory structure of apt/aptitude so it works?

share|improve this question
    
Have you tried recreating them manually to see what it does? –  josten Feb 11 '13 at 3:11
    
What did you do that led you to try to restore status with status-old? –  Jack Feb 11 '13 at 4:26
    
@JMoore, I try to copy file status-odl but no there nothing,nothing in the directory dpkg, so I can't copy file status-old. –  Cristian Chaparro A. Feb 12 '13 at 3:02
    
@Jack, the reazon is that I see in other post that it this was a way to fix the problem. –  Cristian Chaparro A. Feb 12 '13 at 3:06
    
No, I mean what did you do that caused the problem? Or did this seem to just randomly happen? –  Jack Feb 12 '13 at 4:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.