Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

System seems to "hang in the foreground" but continues processing in the background. This appears to happen primarily during operations that rely on 3D acceleration. My system is as follows:

ABit AW8D motherboard, BIOS is latest (1.3)
Corsair 800MHz RAM, 8Gig
Seagate 540Gig HDD
nVidia 9600 GT running on PCIe 1.0b

Ubuntu 12.04 x64
Kernel is 3.2.0-37
nVidia proprietary driver 304.64
Operating mode is 1600x900x32, which is native to the monitor (HP 2009m)

This is a fresh install of Ubuntu. In all other areas, Ubuntu is rock-solid. However, when running applications that are somewhat video intensive and/or memory intensive, the system hangs. The three applications with which this problem arises are VMware Workstation 9.01 when running a client with 3D acceleration enabled, when playing video from within Mozilla Firefox 18.02, or when playing a video in VLC 2.0.5.

When the hang occurs, the mouse cursor either will not move at all, or lags horribly. The display remains as it was at the time the hang occurred, but rewrites do not happen at all. The system stops responding to the keyboard entirely, so the "Ctrl+Alt+F1 sneaking in through an alternate virtual terminal" trick does not work. Only a hard reset "fixes" the problem. I have not tried SSHing into the machine during a hang.

It is interesting to note, however, that the system is still processing. If I am running an application that causes hard drive activity, the hard drive activity continues even after the hang.

This all leads me to believe that the issue is video related.

I have tried:

  • Researching within Google and Ask Ubuntu using the tags ubuntu, 12.04, 9600 GT, nvidia, hang, and combinations thereof. None of the results matched my situation in that the system would respond to an effort to log in to an alternate virtual terminal, whereas my system stops responding to the keyboard.

  • Trying different versions of the nVidia driver. The same issue occurs regardless of driver version.

  • Watching performance across different kernel revisions. This problem has occurred exactly the same way irrespective of kernel revision.

  • Running nvidia-settings with root privileges and saving an xorg.conf file. This has no effect upon the problem.

  • Running Unity without 3D effects. I'm not entirely sure on this one. The 3D effects appear to be present whether logging in using Unity or Unity 2D. In System Settings > Details, the experience is listed as Standard in both instances. However, research within Ask Ubuntu showed that this relates to an incompatibility between Unity and the proprietary driver, but that 3D acceleration occurs anyway.

nvidia-settings shows that all is well, in that resolution, model number and GPU temperature are properly reported.

Any ideas as to where to go from here?

Any logs or other information I might need to post?

Thank you in advance for any help or suggestions you might have.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.