Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using 12.04 on a dual boot Lenovo Thinkpad Edge. Recently the Wi-Fi stopped working on my home network, but still worked on an open network. Other computers in the household, and my ThinkPad, booted off the Windows partition worked fine.

Examining the syslog showed that the computer was able to connect, but was disconnected during the DHCP negotiation.

The wired connection works, so I logged into the router and disabled security. Then the Wi-Fi worked fine. However, leaving the network open is not an option.

Examining /var/log/apt/history.log shows that recently isc-dhcp-common was updated. I suspect that the problem started there.

The bottom line is that with encryption enabled in the router, I cannot connect.

Can anyone suggest what I can do here?

Halldór

Relevant bit of syslog follows.

16:27:33  NetworkManager[807]: <info> (eth1): bringing up device.
16:27:33  NetworkManager[807]: <info> WiFi hardware radio set enabled
16:27:33  NetworkManager[807]: <info> WiFi now enabled by radio killswitch
16:27:33  NetworkManager[807]: <info> (eth1): bringing up device.
16:27:34  NetworkManager[807]: <info> (eth1): supplicant interface state: starting -> ready

16:27:34  NetworkManager[807]: <info> (eth1): device state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]

16:27:34  NetworkManager[807]: <info> (eth1): supplicant interface state: ready -> inactive

16:27:34  NetworkManager[807]: <warn> Trying to remove a non-existant call id.
16:27:35  NetworkManager[807]: <info> Auto-activating connection 'Chipie'.
16:27:35  NetworkManager[807]: <info> Activation (eth1) starting connection 'Chipie'
16:27:35  NetworkManager[807]: <info> (eth1): device state change: disconnected -> prepare (reason 'none') [30 40 0]

16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...

16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started...

16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...

16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.

16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) starting...

16:27:35  NetworkManager[807]: <info> (eth1): device state change: prepare -> config (reason 'none') [40 50 0]

16:27:35  NetworkManager[807]: <info> Activation (eth1/wireless): connection 'Chipie' has security, and secrets exist.  No new secrets needed.

16:27:35  NetworkManager[807]: <info> Config: added 'ssid' value 'Chipie'
16:27:35  NetworkManager[807]: <info> Config: added 'scan_ssid' value '1'
16:27:35  NetworkManager[807]: <info> Config: added 'key_mgmt' value 'NONE'
16:27:35  NetworkManager[807]: <info> Config: added 'wep_key0' value '<omitted>'
16:27:35  NetworkManager[807]: <info> Config: added 'wep_tx_keyidx' value '0'
16:27:35  NetworkManager[807]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) complete.
16:27:35  NetworkManager[807]: <info> Config: set interface ap_scan to 1
16:27:35  NetworkManager[807]: <info> (eth1): supplicant interface state: inactive -> scanning
16:27:35  avahi-daemon[809]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::aed:b9ff:fee2:807d.
16:27:35  avahi-daemon[809]: New relevant interface eth1.IPv6 for mDNS.
16:27:35  avahi-daemon[809]: Registering new address record for fe80::aed:b9ff:fee2:807d on eth1.*.
16:27:36  wpa_supplicant[2352]: Trying to associate with 00:1c:f0:66:23:90 (SSID='Chipie' freq=2412 MHz)
16:27:36  NetworkManager[807]: <info> (eth1): supplicant interface state: scanning -> associating
16:27:36  wpa_supplicant[2352]: Associated with 00:1c:f0:66:23:90
16:27:36  wpa_supplicant[2352]: CTRL-EVENT-CONNECTED - Connection to 00:1c:f0:66:23:90 completed (auth) [id=0 id_str=]
16:27:36  NetworkManager[807]: <info> (eth1): supplicant interface state: associating -> completed
16:27:36  NetworkManager[807]: <info> Activation (eth1/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'Chipie'.
16:27:36  NetworkManager[807]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) scheduled.
16:27:36  NetworkManager[807]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) started...
16:27:36  NetworkManager[807]: <info> (eth1): device state change: config -> ip-config (reason 'none') [50 70 0]
16:27:36  NetworkManager[807]: <info> Activation (eth1) Beginning DHCPv4 transaction (timeout in 45 seconds)
16:27:36  NetworkManager[807]: <info> dhclient started with pid 8724
16:27:36  NetworkManager[807]: <info> Activation (eth1) Beginning IP6 addrconf.
16:27:36  avahi-daemon[809]: Withdrawing address record for fe80::aed:b9ff:fee2:807d on eth1.
16:27:36  avahi-daemon[809]: Leaving mDNS multicast group on interface eth1.IPv6 with address fe80::aed:b9ff:fee2:807d.
16:27:36  avahi-daemon[809]: Interface eth1.IPv6 no longer relevant for mDNS.
16:27:36  NetworkManager[807]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) complete.
16:27:36  dhclient: Internet Systems Consortium DHCP Client 4.1-ESV-R4
16:27:36  dhclient: Copyright 2004-2011 Internet Systems Consortium.
16:27:36  dhclient: All rights reserved.
16:27:36  dhclient: For info, please visit https://www.isc.org/software/dhcp/
16:27:36  dhclient: 
16:27:36  NetworkManager[807]: <info> (eth1): DHCPv4 state changed nbi -> preinit
16:27:36  dhclient: Listening on LPF/eth1/08:ed:b9:e2:80:7d
16:27:36  dhclient: Sending on   LPF/eth1/08:ed:b9:e2:80:7d
16:27:36  dhclient: Sending on   Socket/fallback
16:27:36  dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
16:27:37  avahi-daemon[809]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::aed:b9ff:fee2:807d.
16:27:37  avahi-daemon[809]: New relevant interface eth1.IPv6 for mDNS.
16:27:37  avahi-daemon[809]: Registering new address record for fe80::aed:b9ff:fee2:807d on eth1.*.
16:27:39  dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
16:27:46  dhclient: last message repeated 2 times
16:27:46  kernel: [28901.182673] eth1: no IPv6 routers present
16:27:48  dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
16:27:51  dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
16:27:56  NetworkManager[807]: <info> (eth1): IP6 addrconf timed out or failed.
16:27:56  NetworkManager[807]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
16:27:56  NetworkManager[807]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) started...
16:27:56  NetworkManager[807]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) complete.
16:27:59  dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
16:28:04  NetworkManager[807]: <info> (eth1): device state change: ip-config -> unavailable (reason 'none') [70 20 0]
16:28:04  NetworkManager[807]: <info> (eth1): deactivating device (reason 'none') [0]
16:28:04  NetworkManager[807]: <info> (eth1): canceled DHCP transaction, DHCP client pid 8724
16:28:04  avahi-daemon[809]: Withdrawing address record for fe80::aed:b9ff:fee2:807d on eth1.
16:28:04  avahi-daemon[809]: Leaving mDNS multicast group on interface eth1.IPv6 with address fe80::aed:b9ff:fee2:807d.
16:28:04  avahi-daemon[809]: Interface eth1.IPv6 no longer relevant for mDNS.
16:28:04  NetworkManager[807]: <info> Policy set 'Wired connection 1' (eth0) as default for IPv4 routing and DNS.
16:28:04  NetworkManager[807]: <info> Policy set 'Wired connection 1' (eth0) as default for IPv4 routing and DNS.
16:28:04  NetworkManager[807]: <info> (eth1): taking down device.

I still haven't figured out how to get this right. In the meantime I can use the wifii with WEP provided I use a fixed IP. I simply checked what numbers are available on the router, and pick one that is unlikely to be picked. Set the dns/mask/gateway and I am all set. Connect without a hitch. Not a satisfactory solution, but a workaround.

-- Halldór

share|improve this question

3 Answers 3

I have faced the same problem before. I am not an expert at this, but have you tried using Edit Connections? May be there is a problem in configuration of the Wifi in Ubuntu. Your internet might work if you fix it. Check the exact configuration used in Windows (shared/open etc). Then use the exact same configuration for Wifi in Ubuntu.

share|improve this answer
    
The fact that it once worked makes it less probable that there is a configuration problem. –  jdthood Feb 11 '13 at 8:49
    
I have gone through the edit tab and tried various configurations. They are the same as on my windows partition, and indeed the same as on an acer netbook also running ubuntu 12.04, installed last year and never updated.... –  stuttungr Feb 11 '13 at 16:13
    
Well, I am sorry. Wish I could be of more help. –  Aki Feb 11 '13 at 20:28

I'm no expert but it looks like it might be a problem with IPv6 addressing. I've experienced a similar problem and fixed it by turning off IPv6. This is, of course, not really a solution to the underlying problem, which would be "why is IPv6 addressing not working?" but it got my wireless working again - might help you as well.

From terminal:

sudo gedit /etc/sysctl.conf

Now add these lines at the end of the sysctl.conf file:

net.ipv6.conf.all.disable_ipv6 = 1

net.ipv6.conf.default.disable_ipv6 = 1

net.ipv6.conf.lo.disable_ipv6 = 1

Save and close, might need to reboot.

share|improve this answer
    
Thanks for the replies. –  stuttungr Feb 11 '13 at 15:42
    
Hi, thanks for the suggestion. This turned off my ipv6 allright but did not change the fact that I could not connect. But it was worth a try. –  stuttungr Feb 11 '13 at 16:18
    
Oh well, sorry I couldn't be more help. Which update was this? I don't think I want it just yet... –  nbm Feb 12 '13 at 12:08
    
I still haven't figured out how to get this right. In the meantime I can use the wifii with WEP provided I use a fixed IP. I simply checked what numbers are available on the router, and pick one that is unlikely to be picked. Set the dns/mask/gateway and I am all set. Not a satisfactory solution, but a workaround. –  stuttungr Mar 19 '13 at 1:46
    
Thanks for the news. Have you updated since and still have the problem? If this was seemingly caused by the update, perhaps it merits a bug report? –  nbm Mar 23 '13 at 20:15

Looking at your syslog....

Association succeeds but the DHCP client receives no reply from the DHCP server to its DHCPDISCOVER packets.

Check your DHCP server configuration: is it set up to reject unknown MAC addresses and is your Wi-Fi interface's MAC address listed?

share|improve this answer
    
Thanks for the idea. I logged into the router and checked. Cannot see any deny list. I tried adding the mac adress of the wifii to a dhcp reserve list, but to no avail. –  stuttungr Feb 11 '13 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.